1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RM 1.1 Permissions not working

Discussion in 'Resource Manager Support' started by toodlez, May 18, 2014.

  1. toodlez

    toodlez Active Member

    Okay so I've installed RM, got a few test posts up and running...

    I've set my registered members, moderators, and admins to the ability to view the entire resource, all images, and rate resources....

    Yet, only me (admin) can see the images and entire post... Registered users, moderators can only see that little snippet and then it says they don't have permission to view the whole post... they also cannot rate the resource.

    The only thing working is the ability to like the resource.. Very strange.

    Help! :)
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. toodlez

    toodlez Active Member

  4. Brogan

    Brogan XenForo Moderator Staff Member

    In which case you must not have the permissions set up correctly.
     
    toodlez likes this.
  5. toodlez

    toodlez Active Member

    When I use "test permissions" it shows up properly for any user... when I login on a test account that is just a registered member it doesn't work
     
  6. toodlez

    toodlez Active Member

    I even cleared cache and tried on other browsers
     
  7. Steve F

    Steve F Well-Known Member

    You should only have to set 'Registered' group view permissions. Remember that all users are defaulted to the Registered user group. Only add additional permissions to groups such as Moderators and Admins.
     
  8. toodlez

    toodlez Active Member

    I have the view permissions set on the "registered group" and every other group other than admin (which has full permissions) set as "not set" and it is still not working
     
  9. toodlez

    toodlez Active Member

    I get this error after seeing the first 150 characters or so of the resource article :

    You do not have permission to view the full content of this resource.

    How do I get rid of that?

    I even put on GUESTS "View resources: YES" and still only get that snippet
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    What permissions do you have set for the resource category?
     
  11. Steve F

    Steve F Well-Known Member

    The Registered user group view permissions should be set to "Allow".
     
  12. toodlez

    toodlez Active Member

    @Brogan
    @Steve F

    Admin Permissions:
    [​IMG]



    Moderator Permissions:
    [​IMG]



    Guest Permissions:
    [​IMG]



    Registered Permissions:
    [​IMG]
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Download Resources is Not Set (No).

    Try setting it to Allow.
     
  14. toodlez

    toodlez Active Member

    That did it... So if I don't allow download resources (I'm using this as a rating system) then there will be nothing to download.
     
  15. Mike

    Mike XenForo Developer Staff Member

    There is an option (in the RM option group) that controls whether users without download permissions can view the full text of fileless resources.
     
  16. toodlez

    toodlez Active Member

    I see that now, thank you kind sir!
     

Share This Page