1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 PayPal upgrades not working

Discussion in 'Troubleshooting and Problems' started by AntonyF, May 31, 2016.

  1. AntonyF

    AntonyF Member


    I have realised that what I thought was a sporadic issue now seem to be a bigger one, and that is people paying for account upgrades are not being upgraded.

    The PayPal part is working - payment received, receipt issued etc.

    But XenForo is showing no sign of the result.

    I moved to Xenforo from vBulletin in January, and there was a number of upgrades made on XenForo (so think I can rule out an upgrade issue) but they stopped shortly after that. No further upgrades are shown as active.

    The last transaction in the log shows:
    Information: No txn_id. No action to take.
    Unknown Account

    Only log entries that involve a successful payment will be attached to a user and user upgrade.

    Unknown Upgrade

    However that was in Jan - there is no further log entries at all.

    Any thoughts?

  2. Mike

    Mike XenForo Developer Staff Member

  3. AntonyF

    AntonyF Member

    We turned off IPN due to getting loads of error emails relating to vBul.

    This did make me wonder if that was the issue but a) it only allows one URL and we have multiple XenForo and b) people were indicating it was irrelevant as XF passed its own URL.
  4. Mike

    Mike XenForo Developer Staff Member

    XF needs IPNs to be enabled. The specific URL in PayPal doesn't necessarily matter, but we recommend setting it to your installation URL if you can.

    If you were getting error emails regarding IPNs, these are presumably recurring subscriptions. You may need to take steps to manually cancel these subscriptions within PayPal as they can't really be imported (the recurring part can't be).
  5. AntonyF

    AntonyF Member

    Thanks Mike. I set advice to everyone to cancel their subscriptions and renew a fresh, and re-enabled IPNs.

    However another problem has now cropped up - and that's no subscriptions are working again, not even new ones. I can see PayPal receipts from customers, but XenForo doesn't seem to 'realise'. Any thoughts?

    Also as a side question is PayPal the only option? I'm getting fed up with constant issues with them.
  6. Mike

    Mike XenForo Developer Staff Member

    PayPal is the only option.

    Can you see entries in the transaction log in XF? If so, are there errors?
  7. AntonyF

    AntonyF Member

    The log is (recently) empty. An entry in July saying payment received for a member, but then nothing since.

Share This Page