• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 "Page Not Found" when revoking "Post New Thread" permission

Wulfspider

Active member
#1
This seems to be a new thing for me after starting to use Xenforo Resource Manager. I can't see why it'd be happening, and there hasn't really been any new changes lately that should affect it. I've tried disabling recent addons, and that had no affect on it.

Essentially, the issue is that it's showing the button for the user group where it's supposed to be revoked, and then errors for everyone Registered and above who tries to "Post New Thread".

Also, this is only for specific nodes that I am trying to disable posting new threads, not the entire user group.

Any suggestions or ideas as to why this may be happening?
 

Biker

Well-known member
#2
Did you actually "revoke" the permission? If so, all groups after that usergroup will be affected as well. Just set the permission to "No" for the usergroup you want to turn off the permission for.
 

Wulfspider

Active member
#3
Did you actually "revoke" the permission? If so, all groups after that usergroup will be affected as well. Just set the permission to "No" for the usergroup you want to turn off the permission for.
"Never" is what you are thinking of, not "Revoke". Revoke only disables that permission for user group, but any other groups above that can have it re-enabled if set to "Yes". I have to use Revoke though, as this is per node. I am not setting this on a global level.

That really isn't the issue though. The issue is that they are still seeing the button, even with it disabled.
 

Biker

Well-known member
#4
No.. Revoke should never be used. Setting a usergroup to yes after that will not work. Set the group you don't want to use the button to Never. Remember, permissions are inherited and setting Revoke high in the tree will filter down to everything else.
 

Wulfspider

Active member
#5
No.. Revoke should never be used. Setting a usergroup to yes after that will not work. Set the group you don't want to use the button to Never.
I don't want to set 20 user groups each time I don't want them all to have a permission, as that is what Revoke is for. This was not an issue for me before 1.1.4. Revoke is exactly what I want to use, and it wasn't meant to be used then it shouldn't be there, but it is as it's meant to be used. The only groups that I want to be allowed to create new threads in these nodes are admins, none of the others. Revoke serves this purpose exactly, not the "No" permission as that just adds more unnecessary work when Revoke was made exactly for this purpose.

Regardless, you're arguing over something that doesn't fix it. The issue is that this should be happening at all, yet it does.
 

Brogan

XenForo moderator
Staff member
#6

Wulfspider

Active member
#8
This seems to have been resolved with the update to 1.2.0 Beta 1. The button no longer shows, which is what it was supposed to be doing before.