1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Error message showing members behind private proxy (denied new thread permissions.)

Discussion in 'Troubleshooting and Problems' started by TerryP, Aug 2, 2015.

  1. TerryP

    TerryP Member

    A member tried to post a new thread on one of my forums and received this message.

    I wasn't aware that this software blocked those. I'm not able to find out where (and suspect I don't want to change it anyway.)

    He's just moved from AT&T's DSL to their U-Verse package which included an upgrade to a new modem/router. It's the second time I've ran into someone with this issue (or something similar) and I'm at a loss for what to suggest.

    It seems like this is a setting coming from the manufacture or from the AT&T installation techs...so I'm thinking it's more on the user end than my end.

    Am I alone with this? Anyone else received as similar bug report on your site?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That's not a XenForo message.
    Perhaps your host can help.
     
  3. TerryP

    TerryP Member

  4. TerryP

    TerryP Member

    Hey Brogan,

    This is the message I received from our host.

    The ip isn't blocked at the server. I'm having one of the data center team check to see if they find blocked in the DC network.

    The seventh post of the thread where the users shows the error screen is a XenForo page. if the block was at the server, he'd see a lightspeed erro, not XF.

    I know brogan said it wasn't a xenforo error but you should also show him the screen.

    As the user can access from locations other than the his router, I'm inclined to also follow that path.
    Here's the screen shot of the message being received from our member.

    1.png

    And I thought I could relax a bit today and work on your featured thread add-on... :cool: :D
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any add-ons installed?

    You can search the phrases and templates to try and identify where that phrase is coming from.
     
  6. TerryP

    TerryP Member

    Yes. One being yours. ;)

    Before I posted this question I turned them off to make sure there wasn't a conflict coming from those. What strikes me here is his problem started after he upgraded his service but AT&T sends me back here...it sure seems like it's a router issue but urljet says it's a XF issue.
    I tried that. I will concede the possibility I've missed when I ran the search. It's likely.

    I'll do that again and get back here if I'm still lost ... thanks again!
     
  7. Mike

    Mike XenForo Developer Staff Member

    Based on the screenshot, it is an error being displayed within the XF wrapper, but it is not a message that XF itself contains. It's almost certainly from an add-on.
     
  8. TerryP

    TerryP Member

    @Mike @Brogan

    Due to google rankings I added an SSL certificate right before this started. You think I'm on the right track now? That's the only ad-on that has been added before this started.
     
  9. TerryP

    TerryP Member

    I just spoke to a DOD guy (not that it means anything in today's environment) but SSL certs are giving message boards hell right now according to what he's telling me. It's not limited to just message forums.

    I've seen this happen on more than one XF forum. How do I get around it?
     
  10. Mike

    Mike XenForo Developer Staff Member

    This is very unlikely to be related to SSL, at least not directly. The error is still being triggered by something such as an add-on. I suspect it's an anti-spam one you've installed, for example. You'll need to disable them all and re-enable them one by one to identify the specific cause.
     
  11. FredC

    FredC Well-Known Member

    Hey @TerryP did you ever solve this? i have narrowed it down to possibility of three plugins..

    Do you possibly have one or any of these installed?

    Country Flags: Im running version 1.3.1
    Semprot Deny Country: Im running version 1.1.2
    TAC Stop Human Spam Im running version 1.3.3
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Searching for the phrase content should identify which add-on it is from.
     
  13. FredC

    FredC Well-Known Member

    I did that and I got zero results.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    The error is probably hard coded in the php files then.

    Posting on the respective add-on threads may be your best bet.
     
  15. Tracy Perry

    Tracy Perry Well-Known Member

    It's SemProt Deny Country I'm pretty sure
    Code:
                    if (0 == $options->semprotDCRBlank && '' == $x_country) {
                        throw $this->responseException($this->responseError(
                            'You are behind private proxy, and we do not allow private proxy. If you believe this is an error, please send e-mail to us.'
    
    That's in the Register.php file.
     
    FredC likes this.
  16. TerryP

    TerryP Member

    @FredC Tracy is correct here; at least on what was causing a few of my members issues. Every one was dealing with AT&T though I don't know if that's a "universal cause."

    I deleted the add-on and no more issues except for spam coming from one specific country.

    Due to work obligations, I haven't had the time to change a few settings ... but, it's my thought if I use the two-step verification on new registrations, then move them to a new user group after a few post that doesn't require the same, I should be OK. Luckily, all these bastids spamming my forum always do so between 3-4 AM ... just when I'm getting home from work so it's not that big of a deal to delete them. I just wanted to avoid the hassle.
     

Share This Page