1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Outdated templates and 1.2

Discussion in 'Styling and Customization Questions' started by John, Jun 20, 2013.

  1. John

    John Well-Known Member

    Does the "Outdated Templates" feature not work in 1.2 Beta1? I ask because none of my 1.1.5 stock styles nor my framework templates show they are outdated...which will make finding the ones I need to make compatible with 1.2 difficult.
  2. RoldanLT

    RoldanLT Well-Known Member

    It works in all my styles.
  3. Code Monkey

    Code Monkey Well-Known Member

    They show as outdated for me John
  4. Shelley

    Shelley Well-Known Member

    Same here @John all templates showed outdated that needed updating for me.
  5. Chris D

    Chris D XenForo Developer Staff Member

    John. You're so awesome they made themselves 1.2 compatible...
    Steve F, John and Shelley like this.
  6. Mike

    Mike XenForo Developer Staff Member

    It's sort of a known issue right now and I'm trying to figure out how best to handle it, but don't install an old style in 1.2. The outdated system only picks things up if you upgrade the installation.

    This is necessary to do the merging as it needs 3 particular versions of the template and it doesn't know how to relate them correctly with a fresh install. (It doesn't use versions any more, as it's designed to compare against more than just the master now. It actually lets you compare against the parent style, meaning people can customize a third party style, update the style, and see their changes that are out of date. The version numbers potentially won't be enough to help there.)

    At best, when importing a style, you'll see if in the outdated list but you won't be able to do a 3 way merge with it. (You'll need to incorporate the changes by hand.)
    CyberAP, Jake Bunce and RobParker like this.
  7. John

    John Well-Known Member

    So if I'd like to get the jump on converting styles, it'll be best for me to upgrade an existing 1.1.5 installation to 1.2?
  8. Mike

    Mike XenForo Developer Staff Member

    John likes this.
  9. CyberAP

    CyberAP Well-Known Member

    Comparing child style with parent is a killer-feature! Thanks!
    Steve F and John like this.

Share This Page