1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Notices Not Displaying [SOLVED]

Discussion in 'Troubleshooting and Problems' started by md_5, Oct 22, 2015.

  1. md_5

    md_5 Well-Known Member

    Running 1.5.0, I've tried everything to figure out why notices are not displaying anymore, but I simply can't find it. Nothing is using any of the hooks, the notices are enabled for all users, and they don't even appear in the html source on the default style.
    This also affects inbuilt notices such as "email confirmation required".
     
    jflory7 likes this.
  2. md_5

    md_5 Well-Known Member

    Even with debug = true and enableListeners = false, and the default style, this issue still occurs.
     
  3. Tracy Perry

    Tracy Perry Well-Known Member

    You didn't clarify that you are using CloudFlare. Do you by chance have rocketloader enabled?
    Or any other BETA features of CF?
     
  4. md_5

    md_5 Well-Known Member

    Nope, and as stated, the actual notices block doesn't even appear in the source html.

    Also checked using:
    curl -H "Host: www.spigotmc.org" http://localhost/ | grep -C 30 "if lt"
    (it should appear just below the outdated ie "if lt" block)
     
  5. Solidus

    Solidus Well-Known Member

    Are you using a notice which you've previously dismissed?
     
  6. md_5

    md_5 Well-Known Member

    Nope.

    Originally noticed this because the confirm email notice wasn't showing for new accounts.
    I even created a test notice to display to everyone and not even guests see it.
     
  7. Robust

    Robust Well-Known Member

    Are you trying the default ones, the floating ones (introduced in 1.5) or do neither work since your XF 1.5 upgrade?

    Strange that it's still not working with enableListeners set to false. What about setting it to false and then create a new style (XF default properties will be added if you make it a child of the root node) and see if it works on that.
     
  8. md_5

    md_5 Well-Known Member

    I only care about default, but floating doesn't work either.

    As mentioned above, I'm already testing with the root style which has 0 customized components.
     
  9. Robust

    Robust Well-Known Member

    And to confirm, the notices system is enabled and it was working on XF 1.4 (pre 1.5 upgrade)?
     
  10. md_5

    md_5 Well-Known Member

    Yes
     
  11. Robust

    Robust Well-Known Member

    Well, a good place to start I guess would be to get a full upgrade package to XF 1.5.2. It doesn't fix a problem with notices, however, in case your uploaded files have a problem (you can also check via file health check ofc) this'd be a way to solve that, and you'd probably need to go to XF 1.5.2 at some point anyway.

    That being said, other than that, not too sure on many more solutions at this time. I mean, default style, listeners disabled, and the files uploaded correctly should be working fine, provided the database is also fine, the table for the notices to save to is also having values inserted into normally.
     
  12. md_5

    md_5 Well-Known Member

    Files are fine (1.5.0 was a full upgrade). I don't think a 1.5.2 would fix this issue unless @Mike specifically did something for it.
     
  13. Robust

    Robust Well-Known Member

    Nah, it didn't have any specific fixes for notices. Other than that, I guess you might need to wait for a developer.
     
  14. Chris D

    Chris D XenForo Developer Staff Member

    Although this sounds like something you have already tried, I would encourage you to try again, following the steps below.

    Create a new style at Admin CP > Appearance > Styles. Make sure "No Parent" is selected. This will create a brand new style inherited from the Master Data. Activate that style, and create a new notice without any criteria. Additionally disable all add-ons. Does the notice show?
     
  15. Tracy Perry

    Tracy Perry Well-Known Member

    What about a "rebuild master data" from the /install location?
     
  16. md_5

    md_5 Well-Known Member

    Already tried with my default style which has 0 customized components, but just to be sure I made a new no parent style named "Test" and it still happens.
    Not sure if it's practical to disable every addon by unticking all the boxes, but I did disable listeners in config.php and it still happened.
     
  17. Martok

    Martok Well-Known Member

    XenForo 1.5 introduced a Disable All Add-ons button which should make this simple to do. Probably worth doing anyway just to be sure.
     
  18. md_5

    md_5 Well-Known Member

    Testing now!
     
  19. md_5

    md_5 Well-Known Member

    Nope, disabled every addon and the issue still persists :(
     
  20. Chris D

    Chris D XenForo Developer Staff Member

    Please submit a ticket with log in details. We ought to take a quick look. (Full Admin access will be useful, FTP too if it's easy enough to provide).
     

Share This Page