1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

not receiving confirmation email from register

Discussion in 'Server Configuration and Hosting' started by ozm8ey, Nov 21, 2015.

  1. ozm8ey

    ozm8ey Member

    Hello I'm having this problem thats really doing my brain in. Basically when someone register they don't receive a confirmation email. I have tried different settings, both SSL and TSL and non encrypted. Look at screen shot:

    [​IMG]

    Any ideas?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Unless you have a particular reason to use SMTP, we recommend the default PHP method.

    If you are using the default PHP mail function and there are no errors in the ACP, then this means the emails have been handed off to the server.

    At that point XenForo is no longer involved so you would need to check the mail server log to see whether they are being sent or not.

    Your host should be able to help with that if you are unsure how to check the log.

    If they are being sent then it could be any number of reasons why they aren't being delivered.
    This resource should help: https://xenforo.com/community/resources/dealing-with-spam-filters.366/
     
  3. ozm8ey

    ozm8ey Member

    yeah i tried the default settings first but that didn't work so i contacted my host and they told me to try those settings and gave me all the details but it seems to not work either.
     
  4. WSWD

    WSWD Well-Known Member

    Are people just not receiving the registration emails, or are they not receiving other emails as well, i.e. when PMs are delivered, updates to threads, etc.? Also, is it just for some people, or is nobody at all receiving the mails?

    You're hosted with ColoCrossing (or one of their resellers) and they are infamous for being on spam blacklists and harboring spammers. In fact, they were one of the top in the world at one point. Even though they cleaned up their act considerably, many providers still blacklist their entire IP address space. As far as blacklists are concerned, your IP address is currently on several blacklists. Could be the issue as well, assuming everything is working on the server. Have you checked your exim/mail logs (if you have access) to see what's going on?
     
  5. ozm8ey

    ozm8ey Member

    Hello guys, it seems to send confirmation with my yahoo account but when i use a hotmail account to test it, it doesn't work. Any reason why this could be? Also I have checked spam/junk folder
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. WSWD

    WSWD Well-Known Member

    Yes...because your server IP is blacklisted on at least 6 or 7 blacklists. They aren't really the major ones, like Spamhaus and such, but they're blacklisted nonetheless.

    As far as Hotmail, it's not just a "lately" thing. They have been militant about their emails for years. Even if you're on no blacklists, Hotmail always seems to blacklist your server. The funny thing is, I receive more spam on my old Hotmail account than all my other email accounts combined. So all the good their blocking is doing...
     

Share This Page