1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Not open sections

Discussion in 'Troubleshooting and Problems' started by leito, Sep 11, 2013.

  1. leito

    leito Member

    Install a forum on the same domain. Moved it to the second (without partitions). Created a couple of sections and their forums. When you click on any one of them in the url is added "forum" (and is constantly adding: site.com/forum/forum/forum...), but nothing happens. This board is in a sub-domain (forum.site.com). How to solve? Thank you! Sorry for eng.
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    It adds /forum/ every time? Disable listeners and try again, this sounds like an add-on interfering with link building.
     
  3. leito

    leito Member

    yes, every time when i click any forum. What is listeners?
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

  5. leito

    leito Member

  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    What's your URL?
     
  7. leito

    leito Member

    Hi. Reinstall the forum, but the problem remains. Send URL to PM.
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    What's your .htaccess file? Does it work if you disable full friendly URLs?
     
  9. leito

    leito Member

    Yes, if i disable full friendly URLs, forum works normally. But I need Friendly URLs. Thx.
     
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    What is your .htacess file's contents?
     
  11. leito

    leito Member

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    #</IfModule>

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  12. Jeremy

    Jeremy XenForo Moderator Staff Member

    Try uncommenting the RewriteBase line and change it to be just the root directory.
     
  13. leito

    leito Member

    Internal Server Error
    bla bla bla

    Maybe it's because my forum on a subdomain?
     
  14. Mike

    Mike XenForo Developer Staff Member

    If you submit a ticket with FTP information, I will attempt to look into it.

    This is likely a server configuration issue though, so changes may be limited.
     
  15. Mike

    Mike XenForo Developer Staff Member

    The RewriteBase line sorted it. (The 500 ISE was from an incorrect RewriteBase -- make sure the path is specified correctly if uncommenting it.)
     
    Adam Howard likes this.

Share This Page