XF 1.5 NoCaptcha on Contact Us form

Lloyd32552

Member
After upgrading to 1.5 (I'm pretty sure it was there before), there is no Captcha of any sort on my forum Contact Us form and bots are merrily having their way with me. I'm sure I'm overlooking something simple, but I cannot see anywhere in Options where to enable NoCaptcha on this form.

It is still there on my Registration form, though, thankfully.
 

Lloyd32552

Member
hmm. When I click the Contact Us link at the bottom of the page, I get this form:
upload_2017-1-1_7-22-36.png

What I'm trying to prevent is being bombarded by this:
upload_2017-1-1_7-23-43.png
 

Mike

XenForo developer
Staff member
The CAPTCHA is only displayed to guests. Is that a registered user? If so, you would want to ban/spam clean the user.
 

Lloyd32552

Member
Thanks Mike. I thought I was logged out when I clicked the Contact Us link, but I can see that was not the case.

I don't have a registered user with that name so it appears they have found a way around NoCaptcha which is a shame. I can filter the spam emails. So far, they all appear to be coming from the same IP address so I suspect I can block that at my hosting company.
 

Tracy Perry

Well-known member
I don't have a registered user with that name so it appears they have found a way around NoCaptcha which is a shame.
Well, if it's a human spammer (which is happening from users in India, etc) then it's working the way as intended... which is allowing a human to input captcha info/response and then enter the message.
 
Top