1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 No Email and cant Login

Discussion in 'Troubleshooting and Problems' started by balkanminion, Feb 12, 2016.

  1. balkanminion

    balkanminion Member

    Hello,

    my homepage balkanonline.net doesnt sends any mails. And when i want to Login as Admin, i need the 2 step verification via e-mail, but i dont get any mail.

    Also password recovory isnt, working. Please help me. Thank You
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    To temporarily disable 2FA, add this to the library/config.php file:
    Code:
    $config['enableTfa'] = false;
    Then you can log in, disable 2FA for your account and/or uncheck the option for it related to ACP access, and check the error log for any entries relating to failed emails.
     
    balkanminion likes this.
  3. balkanminion

    balkanminion Member

    Its on Standard Method, what i need 2 change? Can some1 maybe help me, becouse i am new to Xenforo and i think this problem i have some weeks.
    Many Users didnt came back after change to Xenforo, i think its becouse this problem.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Are there any entries in the error log?

    If not, this means the emails have been handed off to the server.

    At that point XenForo is no longer involved so you would need to check the mail server log to see whether they are being sent or not.

    Your host should be able to help with that if you are unsure how to check the log.

    If they are being sent then it could be any number of reasons why they aren't being delivered.
    This resource should help: https://xenforo.com/community/resources/dealing-with-spam-filters.366/
     
  5. balkanminion

    balkanminion Member

    No, not about mail, but many about Tapatalk.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to follow the steps I posted then.

    For the TT errors you can post in the resource thread or contact the author for support.
     
  7. balkanminion

    balkanminion Member

    I tried many things and it dont works, i would be happy if any can help me there.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    I have posted the steps above you need to take.

    If you are unable to get it working using PHP then you can try using SMTP.
     
  9. balkanminion

    balkanminion Member

    I tried, but it doesnt work..
     
  10. balkanminion

    balkanminion Member

    Why i am getting Notifications E-Mails, but the others not?
     
  11. Mike

    Mike XenForo Developer Staff Member

    This demonstrates that XenForo is sending the mail and it's being rejected (or sent to spam) elsewhere. This is where the raw mail logs will give more information. Since this needs root access, your host will have to look at them for you to pull out examples (which should show the reaction from the receiving servers).
     
  12. balkanminion

    balkanminion Member

    Last edited: Feb 12, 2016
  13. Mike

    Mike XenForo Developer Staff Member

    MX records are for receiving mail. If you're using the default PHP mail settings in XenForo, it's handing off to what you configured PHP to use (probably an MTA like Postfix). If you have root, you may find your mail log in a file like /var/log/maillog.
     
    balkanminion likes this.

Share This Page