Nginx and/or htaccess Help

Slyk

Member
In xf1, I have addon [TH] Shorter Routes, which did the following:

forums--
default: http://<domain>/forums/<forumName>.<forumID>/
w/ addon: https://<domain>/<forumName>.f<forumID>/

threads--
default: http://<domain>/threads/<threadName>.<threadID>/
w/ addon: https://<domain>/<threadName>.t<threadID>/

tl;dr: removes "forum" or "threads" from the URL & drops in a "f" or "t" prefix to the ID


Seeing as this addon doesn't exist in xf2, when upgrading, all of my SEO/links will break. Per the discussion in the addon link, here's what I've been attempting (and failing) to put into place:

nginx.conf
rewrite ^/[^\./]+\.f([0-9]+)/$ /forum/forums/$1/ permanent;
rewrite ^/[^\./]+\.t([0-9]+)/(.*)$ /forum/threads/$1/$2 permanent;

.htaccess
RewriteRule ^[^\./]+\.f([0-9]+)/ /forums/$1/ [R=301,L]
RewriteRule ^[^\./]+\.t([0-9]+)/ /threads/$1/ [R=301,L]


full nginx.conf:
Code:
user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
    worker_connections 768;
    # multi_accept on;
}


http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}

location / {
    rewrite ^/[^\./]+\.f([0-9]+)/$ /forum/forums/$1/ permanent;
    rewrite ^/[^\./]+\.t([0-9]+)/(.*)$ /forum/threads/$1/$2 permanent;
}

#mail {
#    # See sample authentication script at:
#    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#    # auth_http localhost/auth.php;
#    # pop3_capabilities "TOP" "USER";
#    # imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#    server {
#        listen     localhost:110;
#        protocol   pop3;
#        proxy      on;
#    }
# 
#    server {
#        listen     localhost:143;
#        protocol   imap;
#        proxy      on;
#    }
#}

full .htaccess:
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    RewriteRule ^/[^\./]+\.f([0-9]+)/$ /forums/$1/ [R=301,L]
    RewriteRule ^/[^\./]+\.t([0-9]+)/(.*)$ /threads/$1/$2 [R=301,L]
</IfModule>


Any idea on why these aren't behaving as expected?
 
Top