1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 New threads not being indexed by Google?

Discussion in 'Troubleshooting and Problems' started by Amin Sabet, Aug 18, 2016.

  1. Amin Sabet

    Amin Sabet Well-Known Member

    For my site: https://www.mu-43.com

    It used to be that if I were to Google a unique or unusual thread name a few hours after it was posted, that thread would come up in the search results every time, without fail.

    These days, threads generally do not come up in a search, even if I wait a few days and the thread has many replies.

    Take for example this thread: https://www.mu-43.com/threads/deet-based-bug-spray-around-camera-equipment-bags.86372/

    A search for

    Code:
    "Deet-based bug spray around camera equipment/bags..."
    doesn't return any results.

    This also returns nothing, indicating that the thread is not indexed:

    Code:
    site:mu-43.com  Deet-based bug spray around camera equipment/bags
    I've tried Googling a lot of other threads that way, and I come up with links to the forum index where threads were linked at one time or another, or page 11 of a thread which I am searching by title, but the actual threads themselves (first page) aren't coming up like they used to.

    Here's what my Sitemap options look like:

    XML.png

    There are no messages or errors showing in Google Webmaster tools, and the sitemap seems to be fine:

    webmaster.png

    My site's direct traffic has held steady over time:

    direct.png

    But Google traffic has steadily declined:

    google.png


    Am I missing something? Is there a better way to submit new thread URLs for indexing?
     
  2. Mike

    Mike XenForo Developer Staff Member

  3. Amin Sabet

    Amin Sabet Well-Known Member

    I think so:

    crawl.png

    Maybe Google just considers my content lower quality than before? Is there any other possible explanation?
     
  4. James

    James Well-Known Member

    I've not used Google webmaster tools for a while but cant you upload a site map and/or ask it to do a re-crawl?
     
  5. Amin Sabet

    Amin Sabet Well-Known Member

    Yes, GWT has my sitemap there and processes it 3 times a week.

    I used to keep recent threads in the sidebar but stopped doing that. I'm going to try putting them back to see if that helps.
     
  6. Amin Sabet

    Amin Sabet Well-Known Member

    My best guess is that I've had too many affiliate links on my site. Was using an addon to automatically convert certain phrases to affiliate links. Probably incurred a Panda penalty. Have removed that addon. Fingers crossed!
     

Share This Page