1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 New Install fails at start - help

Discussion in 'Installation, Upgrade, and Import Support' started by framer, Dec 6, 2013.

  1. framer

    framer Member

    I'm on my own server, fedora core 19

    1. I ran the script to test the server for compatibility with xenForo which passed.

    2. I set the permissions

    CHMOD 0777 data
    CHMOD 0777 internal_data

    verified the permission change

    3. I then open my browser and point it to local.server.name/install

    I get a message that I need to CHMOD the two directories to 0777 which I've already done.

    What am I missing ????

  2. Adam Howard

    Adam Howard Well-Known Member

    Make sure you chmod them as the user and not as root. Also verify that config.php is setup on 644
  3. framer

    framer Member

    My list of permissions and owner

    drwxr-xr-x. 8 root root 4096 Dec 6 13:56 .
    drwxr-xr-x. 4 root root 4096 Dec 6 11:47 ..
    -rw-rw-r--. 1 framer framer 1791 Dec 5 16:22 admindav.php
    -rw-rw-r--. 1 framer framer 415 Dec 5 16:22 admin.php
    -rw-rw-r--. 1 framer framer 359 Dec 5 16:22 css.php
    drwxrwxrwx. 2 framer framer 4096 Dec 5 16:22 data
    -rw-rw-r--. 1 framer framer 974 Dec 5 16:22 deferred.php
    -rw-rw-r--. 1 framer framer 510 Dec 5 16:22 fb_channel.php
    -rw-rw-r--. 1 framer framer 1078 Dec 5 16:22 htaccess.txt
    -rw-rw-r--. 1 framer framer 416 Dec 5 16:22 index.php
    drwxrwxr-x. 4 framer framer 4096 Dec 5 16:22 install
    drwxrwxrwx. 2 framer framer 4096 Dec 5 16:22 internal_data
    drwxrwxr-x. 7 framer framer 4096 Dec 5 16:22 js
    drwxrwxr-x. 8 framer framer 4096 Dec 5 16:22 library
    -rw-rw-r--. 1 framer framer 1378 Dec 5 16:22 payment_callback.php
    -rw-rw-r--. 1 framer framer 1025 Dec 5 16:22 rgba.php
    drwxrwxr-x. 3 framer framer 4096 Dec 5 16:22 styles
    -rwxr-xr-x. 1 root root 20 Dec 6 12:55 test.php

    The errors I'm getting

    XenForo 1.2.3 - Errors

    The following errors occurred while verifying that your server can run XenForo:

    The directory /var/www/html/data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.
    The directory /var/www/html/internal_data must be writable. Please change the permissions on this directory to be world writable (chmod 0777). If the directory does not exist, please create it.

    Please correct these errors and try again.

    Could this be a firewall issue? SElinux issue? The browser pointed to localhost/install.

  4. Mike

    Mike XenForo Developer Staff Member

    It could be an SELinux issue. Basically, if we detect that we can't write to that directory, then we return that error. If you're using an uncommon setup to permissions (and SELinux is very much uncommon), you may need to take extra steps to ensure the directories/created files can be written to.
  5. framer

    framer Member

    SElinux was the issue. It needs to be disabled.

    Thanks for the assist,
  6. framer

    framer Member

    OK the boards up but when I ran the file heath check in admin/tools I got this. All the files are in the xenforo dir there is no xenforo/full dir. I created a xenforo/full dir and moved the file to the correct place and I would then get contents in files not correct.

    Please advise.

    Potential Problems

    1. js/xenforo/full/comments_simple.js File not found.
    2. js/xenforo/full/style_property_editor.js File not found.
    3. js/xenforo/full/xenforo.js File not found.
    4. js/xenforo/full/news_feed.js File not found.
    5. js/xenforo/full/rating.js File not found.
    6. js/xenforo/full/feed_preview.js File not found.
    7. js/xenforo/full/smiley_editor.js File not found.
    8. js/xenforo/full/acp_forum_editor.js File not found.
    9. js/xenforo/full/conversation_invite.js File not found.
    10. js/xenforo/full/form_filler.js File not found.
    11. js/xenforo/full/attachment_editor.js File not found.
    12. js/xenforo/full/options_censor.js File not found.
    13. js/xenforo/full/event_listener.js File not found.
    14. js/xenforo/full/template_edit.js File not found.
    15. js/xenforo/full/avatar_editor.js File not found.
    16. js/xenforo/full/lightbox.js File not found.
    17. js/xenforo/full/sidebar.js File not found.
    18. js/xenforo/full/acp_quicksearch.js File not found.
    19. js/xenforo/full/discussion.js File not found.
    20. js/xenforo/full/inline_mod.js File not found.
    21. js/xenforo/full/title_prefix.js File not found.
    22. js/xenforo/full/cache_rebuild.js File not found.
    23. js/xenforo/full/permission.js File not found.
    24. js/xenforo/full/color_picker.js File not found.
    25. js/xenforo/full/acp_login.js File not found.
    26. js/xenforo/full/filter_list.js File not found.
    27. js/xenforo/full/bb_code_edit.js File not found.
    28. js/xenforo/full/discussion_list.js File not found.
    29. js/xenforo/full/spam_cleaner.js File not found.
    30. js/xenforo/full/personal_details_editor.js File not found.
    31. js/xenforo/full/quick_reply_profile.js File not found.
    32. js/xenforo/full/follow.js File not found.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Upload the files again.
    Use an alternative FTP program if you still experience problems, I recommend WinSCP.
  8. framer

    framer Member

    Strange the archive extracted without the js/full dir I switched extraction programs and it now checks out 100%.

    Now on to the conversion -- from VB4 The db almost a million posting.


Share This Page