1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 New Facebook Integration

Discussion in 'Troubleshooting and Problems' started by CFodder, Jan 5, 2013.

  1. CFodder

    CFodder Well-Known Member

    Tried to setup the facebook integration, followed the FB integration steps as far as I could and setup the app and have the App ID and secret question entered. But when I test integration I get:

    I've tripled checked the AppID and it seems correct, any help would be appreciated. I've attached two screenshots, one of the app setup and the other how it's entered on the site. Thanks.

    facebook app.jpg facebook oldr.jpg
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. CFodder

    CFodder Well-Known Member

    Yeah I followed that when doing it Jake, even though it's a bit out of date now, but am still getting the error.

    I should add can like/recommend pages, but it comes up with the XF logo and not ours.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    You need an App Secret as well as the App ID. Have you removed it from the screenshots?

    Why have you filled in all those other options? (Hosting URL, Canvas URL etc)
     
    Jake Bunce likes this.
  5. CFodder

    CFodder Well-Known Member

    Yeah I have removed the secret from the screenshots. Have filled out the other options just in case there was something there that was causing it ... obviously there wasn't :(.
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    Ok.

    Make sure the secret is correct too. The App Id won't verify without a valid secret. Also make sure there are no spaces in the App Id (especially at the end - possibly by copy and pasting).

    Finally, write down the app id on a piece of paper. Then, remove it from admin cp and type it in manually (no copy pasting).

    You may also want to try creating a new app from scratch, with a new ID.

    Should be filled in like this. NOTHING else:

    [​IMG]
     
    Jake Bunce likes this.
  7. CFodder

    CFodder Well-Known Member

    That got it thanks mate, I think the problem was with the App Domain. What I did was deleted all the other bits I had and re-entered our domain and bingo, it worked.

    Thanks for your help :).

    Now I just have to work out how to get it to display our logo and not the XF one lol.
     
    Chris D likes this.
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    CFodder likes this.
  9. CFodder

    CFodder Well-Known Member

    Wow, thanks for that Jake, all sorted :).
     

Share This Page