1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Multi-Quote Message Previews Not Shown

Discussion in 'Resolved Bug Reports' started by DeltaHF, Aug 1, 2014.

  1. DeltaHF

    DeltaHF Well-Known Member

    I just enabled multi-quote on my site, but the "Insert Quotes..." dialogue box does not show the contents of the quoted messages. Inspecting page source confirms the container is, in fact, empty.

    Screen Shot 2014-08-01 at 1.08.15 AM.png

    Screen Shot 2014-08-01 at 1.08.37 AM.png

    This occurs with both a default theme and my site's custom theme. I disabled all plugins (except for the Resource Manager and Elastic Search) but it did not fix the problem.

    Everything else about the multi-quote feature works normally. Any ideas?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any outdated templates?

    Can you run a file health check and confirm it passes?
  3. DeltaHF

    DeltaHF Well-Known Member

    No outdated templates in any theme, file health check passed.
  4. DeltaHF

    DeltaHF Well-Known Member

    I've done a bit more research. In the thread_multi_quote_overlay template, this is the default text:

    <div class="messageText">{xen:raw $post.messageParsed}</div>
    To verify the contents of $post, I dumped the object with {xen:helper dump, $post} and actually could not find a messageParsed member variable:

    Screen Shot 2014-08-01 at 7.08.41 PM.png

    As a temporary fix, I've changed the template to output the $post.message and it does display as expected, though without the formatting, of course.

    I checked the plugins by disabling each one and then re-loading the multi-quote box. Should I test this in some other way? I suppose that's the only thing that could be causing a problem at this point.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    If the dump is not producing the required content then that can only be an issue with the php files.

    You could try reuploading them.
  6. Mike

    Mike XenForo Developer Staff Member

    Aha. Have you disabled (set to 0) "Discussion Preview Length"? Looks like the code piggybacks on that, but that is probably a bug now that the output is just height controlled.
    DeltaHF and Brogan like this.
  7. DeltaHF

    DeltaHF Well-Known Member

    Yep, that was it! Thanks, Mike.
  8. Mike

    Mike XenForo Developer Staff Member

    I've now fixed the code so that it doesn't depend on this option erroneously.
    DeltaHF likes this.

Share This Page