• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Moving Web Hosts: Errors Inside

Eoj Nawoh

Active member
#1
Hello all,


I'm trying to move from my current hosting to new hosting.

Both forums are XenForo.

This is the error I'm getting:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Apache Server at harpoontrading.com Port 80

I moved the MySQL database and I have changed the config in the library. I can't get to the admin and I tried added debug mode but can't load the site at all.
 

Jake Bunce

XenForo moderator
Staff member
#2
A 500 ISE error is very generic. It is an error returned by your server. To discover the exact cause requires consulting with your host to pull the error logs on the server. Many times this error is caused by an overly restrictive mod_security rule, or some other server module. Contact your host.
 

Eoj Nawoh

Active member
#3
Alright I did.

The error log is as follows:
[Fri Mar 15 03:54:52 2013] [alert] [client 38.100.21.120] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
[Fri Mar 15 03:54:53 2013] [alert] [client 38.100.21.120] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
[Fri Mar 15 06:42:07 2013] [alert] [client 64.202.160.161] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
[Fri Mar 15 06:42:07 2013] [alert] [client 64.202.160.161] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
[Fri Mar 15 06:42:07 2013] [alert] [client 64.202.160.161] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
[Fri Mar 15 06:44:20 2013] [alert] [client 64.202.160.161] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
Which led me to the .htaccess file, and I renamed it.

and now I get:
An exception occurred: Mysqli prepare error: Table 'harpoon.xf_social_forum' doesn't exist in /home/content/11/10724511/html/library/Zend/Db/Statement/Mysqli.php on line 77
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 218
  5. XenForo_Model->fetchAllKeyed() in Waindigo/SocialGroups/Model/SocialForum.php at line 269
  6. Waindigo_SocialGroups_Model_SocialForum->getSocialForums() in Waindigo/SocialGroups/Blocks/NewSocialForums.php at line 13
  7. Waindigo_SocialGroups_Blocks_NewSocialForums->getModule() in Waindigo/SocialGroups/Model/Blocks.php at line 16
  8. Waindigo_SocialGroups_Model_Blocks->getBlockParams() in EWRporta/ViewPublic/Custom.php at line 71
  9. EWRporta_ViewPublic_Custom->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 215
  10. XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlPublic.php at line 67
  11. XenForo_ViewRenderer_HtmlPublic->renderView() in XenForo/FrontController.php at line 533
  12. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 156
  13. XenForo_FrontController->run() in /home/content/11/10724511/html/index.php at line 13
which my guess is the screw up with the backup and import. So I'm sorta of lost, because I thought I imported all the backup'ed database tables.

So I tried again and got:
Error

SQL query:
/*!40000 ALTER TABLE `xf_ip` DISABLE KEYS */;

MySQL said:

#2006 - MySQL server has gone away
 

Jake Bunce

XenForo moderator
Staff member
#5
[Fri Mar 15 03:54:52 2013] [alert] [client 38.100.21.120] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'SecFilterScanPOST', perhaps misspelled or defined by a module not included in the server configuration
Ok so you found the problem in the .htaccess file. That problem is solved.

Mysqli prepare error: Table 'harpoon.xf_social_forum' doesn't exist
This is a different error that is unrelated. This error refers to the Waindigo/SocialGroups addon. Contact the author.

MySQL server has gone away
That error is caused by one of these MySQL settings being exceeded:

wait_timeout
max_allowed_packet

Your host or server person needs to increase these settings in MySQL. There is more info here:

http://dev.mysql.com/doc/refman/5.1/en/gone-away.html
 

Eoj Nawoh

Active member
#6
Ok so you found the problem in the .htaccess file. That problem is solved.



This is a different error that is unrelated. This error refers to the Waindigo/SocialGroups addon. Contact the author.



That error is caused by one of these MySQL settings being exceeded:

wait_timeout
max_allowed_packet

Your host or server person needs to increase these settings in MySQL. There is more info here:

http://dev.mysql.com/doc/refman/5.1/en/gone-away.html
I was told by them to:

NOTE: The phpMyAdmin interface only lets you import 8MB of data at one time. If you need to import more than 8MB, we recommend breaking up the file into 8MB pieces.

NOTE: You do not need to include the CREATE DATABASE line in your MySQL database. If you do include it, your import might fail. We recommend removing the line before importing your database.
 

Eoj Nawoh

Active member
#8
Alright I've fixed everything but the .htaccess file.

I tried using this one
#Mod_security can interfere with uploading of content such as attachments. If you
#cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#SecFilterEngine Off
#SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

SecFilterScanPOST Off

# Values required for Steam XenForo Addon
php_value safe_mode off
php_value open_basedir ""
php_value max_execution_time 180

<IfModule mod_rewrite.c>
RewriteEngine On

#If you are having problems with the rewrite rules, remove the "#" from the
#line that begins "RewriteBase" below. You will also have to change the path
#of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

#This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
However it leads to a 500 Internal server error, and it is the cause. My sitewww.HarpoonTrading.com, won't allow users to leave the page, so what should I change the .htaccess file to?

The error is
[Mon Mar 18 08:48:40 2013] [alert] [client 144.118.210.242] /var/chroot/home/content/11/10724511/html/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
However, wouldn't I need that to be set to use the Steam Login.
 

Jake Bunce

XenForo moderator
Staff member
#9
Your server doesn't support that .htaccess command. Contact your host if you need that command to work. Otherwise those commands might not be needed. Your host or server person can apply those PHP settings directly in the php.ini file on the server, or you can also try adding these equivalent lines to XenForo's library/config.php file:

Code:
ini_set('safe_mode', false);
ini_set('open_basedir', '');
ini_set('max_execution_time', 180);
 

Eoj Nawoh

Active member
#10
I think for the time being I may not need them, as I removed them and the site didn't explode.

Thank you so much for your assistance, collectively, you've made this process easy. Especially you, Jake.