1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Moved host, can't login

Discussion in 'Troubleshooting and Problems' started by Veryard, Aug 26, 2013.

  1. Veryard

    Veryard Formerly BradsFX

    Hello, with myXenforo I have moved hosts and now it says my password is incorrect, I have tried to login to admi.php etc. Still can't get it working.
  2. cbertozz

    cbertozz Member

    I have the same problem...

    The admin password no longer works.
  3. Rigel Kentaurus

    Rigel Kentaurus Well-Known Member

    Is this the case that it gives you an "error", or that it just redirects you again to the same page and asks again for credentials?
    Can you login to the main site?

    If nobody can login at all, that could be cookies.
    In the other case, do a quick look at your xf_user table and make sure that your user is still there. A bad import could leave the table empty (unlikely, you would've noticed)

    The salt and login algorithm is stored in the user table itself, so changing hosts, as long as you restore everything, should be fine

    I believe the XF guys have ticket support here - https://xenforo.com/customers/tickets
  4. jayramfootball

    jayramfootball Active Member

    I have exactly the same error. Just migrated and some passwords do not work whilst others do.

    This is a guess - but i THINK it might be something to do with the fact that RECENT log ins are failing. I think this because I am able to log in with the old RSS feed 'dummy' members that I set up originally but not with my active member account OR my admin account.
  5. Mike

    Mike XenForo Developer Staff Member

    I saw a situation recently where the login would appear to be successful but it would redirect you back and you wouldn't be logged in. The data had just been migrated but there was corruption in the migration. I'm not sure of the details exactly unfortunately.

    I would probably aim to dump and restore the database via the command line (mysqldump and mysql, respectively), though you may need your host to help if you don't have SSH access.
  6. jayramfootball

    jayramfootball Active Member

    @Mike I am going to try and use the command line again. I have checked the database though and all seems fine - every table there, same size, same record count etc...

    The login process just takes you back to the login page saying the user name / password was not valid.
    I am not sure this is data corruption as its too 'neat' top be that.. what i mean by that is some logins work but only where they have not been used for a long period to log in... all the recent logins when the site was on the old server fail.

    Will try re-importing though.

    Can you post the mysqldump and mysql commands here?
  7. Mike

    Mike XenForo Developer Staff Member

    I suppose it could be an issue with the new server lacking some of the hashing functions. Did you migrate to a server with PHP 5.2 (assuming the old one was 5.3)? And what version of XF are you running?
    jayramfootball likes this.
  8. cbertozz

    cbertozz Member

    I can login with a normal user but not Admin, its the admin thats locked out?
  9. jayramfootball

    jayramfootball Active Member

    I am running 1.2

    the old server shows for php 5.3.20

    the new server was on 5.2 (just changed it to 5.3)
  10. jayramfootball

    jayramfootball Active Member

    after the update of the php version i WAS able to login to my user account, however cant log out lol...

    The server responded with an error. The error message is in the JavaScript console.

    i will try admin next once I clear the browser in order to log out...
  11. jayramfootball

    jayramfootball Active Member

    yep can log in to admin now as well... just have the same log out error.
  12. Mike

    Mike XenForo Developer Staff Member

    @cbertozz - If you haven't moved hosts, you'll likely just have to do a lost password recovery (or have another admin recover the password for you). If you have moved hosts, see my post. If you can't switch to PHP 5.3, you (and all users that can't login) would need to use lost password handling. You should really ditch PHP 5.2 though - it's unsupported.
  13. Mike

    Mike XenForo Developer Staff Member

    Disable your add-ons and confirm. Look at the server error log to see if there's any info there (assuming you're running 1.2.1).
  14. jayramfootball

    jayramfootball Active Member

    log out issue is with the add on to restore the log out link to the nav bar.

    The log out works if you use the 1.2 log out when hovering over the user name
  15. jayramfootball

    jayramfootball Active Member

    see next message.

    Also i am running 1.2 (not 1.2.1)

    I have isolated the issue to the restore log out link add on.
    MattW likes this.
  16. jayramfootball

    jayramfootball Active Member

    @Mike thank you for your help on this.
    I have spent hrs with my host and they did not once suggest the issue of the different php versions.

    brilliant stuff.
  17. jayramfootball

    jayramfootball Active Member

    @Mike - it would also be useful to post the ssh commands on this thread - now i have accessed my site there are all sorts of issues (javascript I think) pages not found, inability to put the board active, ... think my database import was corrupted...
  18. Brogan

    Brogan XenForo Moderator Staff Member

    mysqldump -u<user> -p<password> --single-transaction --skip-lock-tables db_name > /path/to/backup/db_name_$(date +%d.%m.%y).sql

    Zip (optional):
    tar -czf db_name_$(date +%d.%m.%y).tar.gz /path/to/backup/db_name_$(date +%d.%m.%y).sql

    mysql -u<user> -p<password> db_name < db_name.sql
    Moddis, jayramfootball and Mike like this.
  19. jayramfootball

    jayramfootball Active Member

    @Mike does xenforo stop connections frmo webproxy 's running scripts or something - or some other kind of restrictions? At the moment I can only access my site through web proxy as the dns propagation is not fully complete...
  20. jayramfootball

    jayramfootball Active Member

    Presumably after the -p you need to put the password in ... so -pPASSWORD ?

Share This Page