1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Members are unable to add comment to profile posts

Discussion in 'Troubleshooting and Problems' started by IPF, Apr 19, 2016.

  1. IPF

    IPF Active Member

    My members are unable to add comments to profile posts.

    Permissions for registered user group shown below. Options are marked not set for other user groups.

    profile posts.JPG

    Users are able to like but not comment.

    profile posts 1.JPG

    What have I missed?

    Thanks,
    IPF
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Use the permissions analyzer to check the final permission value, as there may be a another user group with Never set.

    If the permissions are OK, test in a default style with add-ons disabled, to rule out any third party code.
     
    IPF likes this.
  3. IPF

    IPF Active Member

    Permissions analyzer for that user shows that they can comment. So probably another add on.

    upload_2016-4-19_18-9-30.png

    Thanks @Brogan. Trying this now.
     
  4. IPF

    IPF Active Member

    Still no luck

    All addons disabled

    upload_2016-4-19_18-39-36.png

    Checked in default style

    profile posts 3.JPG
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    One thing to check, you see that "Like" link there.

    Right click it and click "Copy link address" (or similar, depending on browser).

    Now paste that into your browser's address bar, and change the "like" bit at the end of the link to "comment" and go to that address, e.g.

    Change:
    https://xenforo.com/community/profile-posts/26312/like

    To:
    https://xenforo.com/community/profile-posts/26312/comment

    Do they get an error when going to that URL? If so, what is it? Or do they get a comment box?

    Just trying to rule out some template weirdness and verify it is actually a permission error.
     
    IPF likes this.
  6. IPF

    IPF Active Member

    This is the error message

    upload_2016-4-19_18-56-2.png
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    Is this the same for all profile posts and comments or is it specific to profile posts by certain users? And are you certain this affects all users trying to make comments, or just some?
     
    IPF likes this.
  8. IPF

    IPF Active Member

    Weird thing is, I am able to comment in profile posts.

    profile posts 5.JPG

    My permission settings are like this.

    upload_2016-4-19_18-58-15.png
     
  9. IPF

    IPF Active Member

    This is affecting all members except me.
     
  10. Chris D

    Chris D XenForo Developer Staff Member

    I think this could be down to each user's individual privacy settings.

    I just signed up and certainly my default privacy settings I've been given allow any members to post to my profile (this means people can post new profile posts and comments on my profile) however when I go to most people's profiles, I'm unable to post new profile posts, which is why I would be unable to also comment on existing profile posts.

    As an example, if you go to this member's profile:
    http://indianparentsforum.com/community/index.php?members/punita.144/

    And go to Moderator Tools > Edit

    When in the Admin CP edit page for that user, under the Privacy tab, what value is set for "Post messages on this user's profile page:"? I suspect it will either be unchecked or only people they follow.

    You would still be able to post and comment because you are likely to have the Bypass privacy permission.
     
    IPF likes this.
  11. IPF

    IPF Active Member

    That was the issue. :) I will let my members know. Thanks @Chris D

    upload_2016-4-19_19-12-5.png
     
    Chris D likes this.

Share This Page