1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Member reported not able to Upload a File using iOS 9

Discussion in 'Resolved Bug Reports' started by AndyB, Sep 21, 2015.

  1. AndyB

    AndyB Well-Known Member

    I have a member reporting he cannot Upload a File using iOS 9. The error message is:

    He's trying to upload a picture to a post.
    Last edited: Sep 21, 2015
  2. Chris D

    Chris D XenForo Developer Staff Member

    There has been another report of this, but it is, as yet, something I can't reproduce.

    I will do some more testing.

    Which browser were they using, and which specific model of Apple device was it?
  3. Chris D

    Chris D XenForo Developer Staff Member

    Could you also share your allowed extensions list from Options > Attachment Options
  4. AndyB

    AndyB Well-Known Member

  5. AndyB

    AndyB Well-Known Member

    Turns out it's only one member having this problem, so I edited the title and post to reflect this.

    He's using the iPhone 5S with the Chrome browser.
  6. Chris D

    Chris D XenForo Developer Staff Member

    This is the problem.

    iOS can store pictures, or at least output them to the browser, with a .jpeg extension. Please add jpeg to the list and see if that resolves the problem for that user.
  7. AndyB

    AndyB Well-Known Member

    That's what it was. I added the .jpeg extension and now he can Upload a File without any problems.

    Thank you, Chris.
  8. Chris D

    Chris D XenForo Developer Staff Member

    Just for future reference, that jpeg extension is added by default when XF is installed so it must have been removed manually at some point. Worth keeping the default ones :)
    DerTobi75 and AndyB like this.

Share This Page