Fixed Member Profile's warning link is incorrect

Affected version
2.0.2

Xon

Well-known member
In member_macros:
HTML:
<a href="{{ link('members', $user) }}#warnings"
This should be an XF2 style link not an XF1. Something like link('members/warnings', $user) (maybe in an overlay?)
 
Last edited:

Chris D

XenForo developer
Staff member
We did it like that deliberately as we didn't see a particular need to change it. It takes you to the correct page with the correct info displayed, so it's hardly incorrect.
 

Xon

Well-known member
We did it like that deliberately as we didn't see a particular need to change it. It takes you to the correct page with the correct info displayed, so it's hardly incorrect.
In that case, whatever changes tab isn't working when clicking on the link. It bounces to the profile post tab and doesn't move.

Reloading the page works at least
 

batpool52!

Well-known member
Doesn't work for me as well if I just go to a profile and then click on Warnings found under member header stats or click on the Warnings tab and then click on the click under member header stats again.
profile_hash_not_working_1.png

Happens on Windows 10 and Firefox 58.02
 

Chris D

XenForo developer
Staff member
It wasn't previously clear that it was that link which was causing it. It works as designed if you're not already on the member profile.
 

Chris D

XenForo developer
Staff member
This is fixed now by way of reacting to the hashchange event to activate the Warnings tab.
 
Top