1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Media Thumbnail Problem

Discussion in 'Media Gallery Support' started by Hugh Edwards, Sep 25, 2015.

  1. Hugh Edwards

    Hugh Edwards Member

    Hello Everyone,

    I have noticed an issue recently where adding YouTube clips into the Media browser works, but the thumbnail image pulled in from YouTube breaks. Ideally I'd like to be able to add my own thumbnails to this, but that aside, a working model would do! I haven't changed anything since it was installed, no permissions changes etc.

    In this image you can see the 3 older media clips (at the bottom) with the thumbnails pulled in from YouTube and then the most recent three there (at the top) with broken images. Any ideas? :)

    Screen Shot 2015-09-25 at 11.42.01.png
  2. Chris D

    Chris D XenForo Developer Staff Member

    What version of the gallery do you have installed?
  3. Hugh Edwards

    Hugh Edwards Member

    Hello Chris,

    It's 1.0.2. What's strange though is that this has worked for months, and nothing's changed on our end?!
  4. Chris D

    Chris D XenForo Developer Staff Member

    Well, judging by the screenshot, the last time it worked was around 4-5 months ago in May.

    Which, incidentally, was around the same time we released version 1.0.5a to specifically solve this issue:


    YouTube changed the API, we fixed it. The recommended course of action is to upgrade. The current version is 1.1.1 which requires XF 1.5. If you're sticking with XF 1.4 then you'll need to install version 1.0.9.
  5. Hugh Edwards

    Hugh Edwards Member

    Hi Chris,

    Aha! I will try that, thank you! :)

  6. Hugh Edwards

    Hugh Edwards Member

    Hi Chris,

    I did the upgrade and it's successfully now showing 1.0.5. Then tried to embed a new YouTube clip, and it's still not creating the thumbnail - still broken - do I need to restart something for this to take effect etc?
  7. Chris D

    Chris D XenForo Developer Staff Member

    Realistically 1.0.5 should work but really I wouldn't recommend a version below 1.0.9.

    Upgrade to that first and try again.

    Also ensure all the files have been uploaded overwriting any existing files.

    Try it with videos from another supported service too.

    Also try it with a video you have never embedded before.

    If problems persist please open a ticket from your customer area with login details and I'll take a closer look.

Share This Page