1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mandatory Location 1.3.3

Requires new users to enter a location during registration

  1. ceribik

    ceribik Active Member

    ceribik submitted a new resource: Mandatory Location

    Requires new users to enter a location during registration

    Read more

    Want to support future development and other mods? Feel free to make a donation:

  2. Rob

    Rob Well-Known Member

    Added criteria..... Can you tell me where this criteria is used? On emailing, trophies, notices?
  3. ceribik

    ceribik Active Member

    The only one I've tried it on is on notices. Basically, you can use it to make notices only show to people who haven't set a location.

    If emailing and trophies use the same set of criteria, it should be available there too.
  4. Garamond

    Garamond Well-Known Member

    Does this still work?
  5. ceribik

    ceribik Active Member

    Not sure, you'd have to test it as I don't use it myself. If I had to guess, I'd say probably not considering the registration changes in the latest version of XF.
    Garamond likes this.
  6. optrex

    optrex Active Member

    I'd like to get this confirming to work in 1.2 if at all possible.
  7. DRE

    DRE Well-Known Member

    No longer working in Xenforo 1.2 :(
  8. Chris D

    Chris D XenForo Developer Staff Member

    This might not need an add-on.

    How confident are you that your users are mostly using a modern web browser?

    If you don't mind a few slipping through the net (because they use an older browser) you can edit the template and add this to the HTML tag for the Location input:


    If they have a HTML5 browser then this will happen when they submit the form without that filled in:

  9. Don

    Don Member

    Which template are you referring to?
  10. Chris D

    Chris D XenForo Developer Staff Member

    I sort of forgot that the Location field isn't included on the registration form.

    In what way isn't it working anymore in 1.2?
  11. DRE

    DRE Well-Known Member

    Like you said it doesn't show up on the registration form so when someone tries to register it says they have not filled out their location. This has been broken for awhile now and I'm ashamed to say that I'm only just now discovering this. This is embarrassing because my members have been inviting their friends and none of them have been able to join. I only found out today when a friend I asked to join was right next to me on her kindle when she tried and it didn't work.
  12. optrex

    optrex Active Member

    what have I done differently then, because its working for me on 1.2
  13. ceribik

    ceribik Active Member

    There are two highly probably reasons why you're experiencing this.

    Looking at the options BASE/admin.php?options/list/MandatoryLocationOptions

    Case 1:"Automatically Add Template Changes" disabled (this should be what @optrex is using).
    You forgot to readd the template change

    Case 2:"Automatically Add Template Changes" enabled
    -This experimental feature is broken in 1.2.

    Assuming your issue is case 2, I don't really have time to fix the addon unless you're willing to pay and so I'd recommend either:
    a) Disabling the addon and using @Chris Deeming 's advice (keeping in mind the tradeoff), OR
    b) Adding the template change yourself (see step 3 of the instructions)
  14. craigiri

    craigiri Well-Known Member

    Well, I'd add $25 US to the pot if any of you other characters want to pony up......this is a nice add-on, and I'm sure lots of people could use it.
  15. Alfa1

    Alfa1 Well-Known Member

    Why not fetch the location from the browser or IP?
  16. craigiri

    craigiri Well-Known Member

    Many mobile and other networks users report as being a different location. Other people have multiple houses (go south or north for part of the year), yet for purposes of our board want a single location specified.
  17. Wesker

    Wesker Active Member

    I haven't been able to get this to work in 1.2.1.
  18. craigiri

    craigiri Well-Known Member

    So here's my problem and basic questions...

    I have thousands of members who signed up and entered their location(s). Even though this add-on is disabled, those are still there, but new members are not forced to enter theirs. I also have no control over that field....or don't think I have.

    So did this add-on actually install a field and my db is now populated with that data...and, in turn, I can't use it if I install another custom field for location? Is this going to require some custom work?
  19. ceribik

    ceribik Active Member

    All this addon does (or did) was force users to enter in a value for the default location field (that is a part of XF). It does not make any special changes to the database.
  20. DRE

    DRE Well-Known Member

    Does this work for you in Xenforo 1.2.2?

Share This Page