Resource icon

Mandatory Location 1.3.3

No permission to download

russoroni

Active member
Bummer. I really want to use this in conjunction with Xenforo User Map but even with the location field hacked into the honey pot registration form after user registration the username gets all screwed up and replaced with a string of seemingly random characters.
 

ceribik

Well-known member
Since I don't really have the time, and XF 1.3 is not yet released, I can't update the addon. If you remind me sometime in late March, I can probably do so then.
 

russoroni

Active member
Since I don't really have the time, and XF 1.3 is not yet released, I can't update the addon. If you remind me sometime in late March, I can probably do so then.
Thanks ceribik. Until today I didn't realize that location isn't even in the registration form. Is this because of fool honeypot or is this a xen 1.2 thing? Is there a way I can just get the field in the registration form?
 
Last edited:

russoroni

Active member
I got this working on Xenforo 1.3 by adding this in the Foolbothoneypot_register_form template.

Code:
    <dl class="ctrlUnit">
        <dt><label for="ctrl_location">{xen:phrase location}:</label></dt>
        <dd>
            <input type="text" name="location" value="{$fields.location}" class="textCtrl" id="ctrl_location" />
            <p class="explain">{$xenOptions.MandatoryLocationPhraseRegLoc}</p>
        </dd>
    </dl>
On default xenforo you would add this to register_form

The reason it wasn't working for me before is because the template modification in this addon was trying to find and replace: <dl class="ctrlUnit OptOut"> which is no longer in the latest versions of Xenforo.
I followed these instructions but the location field doesnt show up in the user profile. Is this working for you?
 

ceribik

Well-known member
Reactions: DRE

ceribik

Well-known member
Doesn't work for me in xf 1.3. This code is already in register_form but it doesn't work anyway.
So this is why registrations have been down since late last week (updated to 1.3). Thankfully a guy used the contact us field to let me know.
Sounds good to me!
Yeah I am looking forward to it to! Cool~!
This again stoped working on xenforo 1.3, anyway to fix it , tnx ?
New version is out for XF 1.3.
 

russoroni

Active member
Thanks alot @ceribik for getting this back up and running. I hate to be an ingrate but do you think it would be possible to make this work with foolpothoneypot? That addon is invaluable for blocking spambots from the registration form. I really need to use your addon but I hate the thought of disabling honeypot. Heres the link to what I'm talking about if you don't know:

http://xenforo.com/community/resources/foolbothoneypot-bot-killer-spam-combat.1085/
 

ceribik

Well-known member
Thanks alot @ceribik for getting this back up and running. I hate to be an ingrate but do you think it would be possible to make this work with foolpothoneypot? That addon is invaluable for blocking spambots from the registration form. I really need to use your addon but I hate the thought of disabling honeypot. Heres the link to what I'm talking about if you don't know:

http://xenforo.com/community/resources/foolbothoneypot-bot-killer-spam-combat.1085/
In what way is it incompatible? i.e. what errors, etc do you see?
 

ceribik

Well-known member
Thanks alot @ceribik for getting this back up and running. I hate to be an ingrate but do you think it would be possible to make this work with foolpothoneypot? That addon is invaluable for blocking spambots from the registration form. I really need to use your addon but I hate the thought of disabling honeypot. Heres the link to what I'm talking about if you don't know:

http://xenforo.com/community/resources/foolbothoneypot-bot-killer-spam-combat.1085/
I realise this is an old post, but this is probably because that addon also messes around with the registration code. It's hard to say for sure, as that addon costs $$. In any case, I have a new version you might want to try.
I took a look at the free version and It seems I was right. The only way to make this addon compatible with FoolBotHoneyPot would be to edit one of their files.

1. Open library/Tac/FoolBotHoneyPot/ControllerPublic/Register.php
2. Find (~ line 502)
PHP:
$writer->setCustomFields($customFields, $customFieldsShown);
3. Replace that with
PHP:
$writer->setCustomFields($customFields, $customFieldsShown);

// MandatoryLocation
if (!$data['location'] || $data['location'] == '')
{
    $writer->error($options->MandatoryLocationPhraseRegLocError, 'location');
}
4. You might have to delete the actionRegister() function in library/MandatoryLocation/ControllerPublic/MandatoryLocation.php too

It should work now (assuming the template edits still work)
 
Last edited:
Top