1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mailchimp add on still working?..

Discussion in 'Resource and Add-on Discussions' started by Jay182uk, Apr 14, 2014.

  1. Jay182uk

    Jay182uk Member

    Hi guys, I have recently set up a forum and I wanted to integrate my MailChimp newsletter list to it,

    I saw this when searching on the forums (from a couple of years ago)

    so I uploaded the appropriate files to my server and installed the add-on. The add-on works in that the installation went fine and I ensured it was enabled, then I attached my Mailchimp API key and suddenly, on registration, New Users are now confronted with a 'signup to newsletter' box that is automatically checked by default..

    However, on testing it by registering as a new dummy user, the user registered fine to the forum...
    but the user was not logged on Mailchimp at all. The list on Mailchimp still shows that it has 0 subscribers and 0 visitors.

    Perhaps it takes Mailchimp a few hours to update its list of subscribers? but I doubt this.

    anyone know what might be wrong - maybe the add on is obsolete in some way?

    Any info would be awesome.

    thanks guys.
  2. petertdavis

    petertdavis Well-Known Member

    I'm using it and still get new signups every day for my Mailchimp mailing list. Go sign up on my Stamp Forum if you want to see it in action. I'm not sure why yours might not be working, it makes me wonder about mine now though, I get the notifications that new people are joining my MC newsletter but I haven't really been tracking what percentage of new members get signed up or not.
  3. Jay182uk

    Jay182uk Member

    everything seems to be in order apart from the fact that the new users registering and selecting the box 'sign up for newsletter' when registering to my forum, arn't then showing up as subscribed members on my newsletter on MailChimp - So at the moment it's pretty much useless? =/
    if the user visits their settins on the forum, and clicks on 'newsletter' from the right hand sidebar, they have the option to sign up then, and when selecting subscribe and hitting submit, it then triggers a confirmation email thats sent to them..

    but as for signing them up to the newsletter on signing up to the forum, nothing seems to be happening?
  4. Andy.N

    Andy.N Well-Known Member

    Check out the Mailchimp log under Tools in your XF ACP. It should show who signed up.
  5. Jay182uk

    Jay182uk Member


    Hi andy, thanks for the advice. it shows this:


    3 errors in red under method 'listSubscribe' and when I click on one it says what it says on the image above ^

    could this because my list is asking for a first name/last name instead of just an E-mail address from the user? because obviously when signing up to my forum they wouldnt be inputting their first and last names?
  6. xfrocks

    xfrocks Well-Known Member

    That's the cause. MailChimp error message was about FNAME, I assume it will ask for LNAME after that.
  7. barryhynd

    barryhynd Member

    Can I just ask does this add on still work then? I disabled it a while back as I thought it was out of date?

    Is it not feasible to keep it up to date? Surely a lot of people use Mailchimp?
  8. polle

    polle Active Member

    I am looking for a mail chimp add-on as well. Has anyone try that old one this days?

Share This Page