• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
[KL] Editor Manager

[KL] Editor Manager 1.0.0 Beta 3

No permission to download

katsulynx

Well-known member
#1
katsulynx submitted a new resource:

[KL] Editor Manager - Customize Your WYSIWYG-Editor & BbCodes.

[KL] Editor Manager
Description
Fully customize your XenForo Froala instance. Change your toolbar layout, enable and disable BB Codes, make use of the new table and background-color BB Codes, provide exciting new fonts for your users from your own server or external hosts. It's all in your hands.

Features
  • Enable and...
Read more about this resource...
 

katsulynx

Well-known member
#4
I can’t see screenshots.
Thanks, should be sorted now.

do you have example site for test this addon ?
Nope. Considering that most of the stuff takes plase in the admin control panel, that wouldn't really be feasible anyway. But it's free, for as long as you don't use it for commercial purpose! So you can download and install it on your test installation to try it!
 

katsulynx

Well-known member
#5
katsulynx updated [KL] Editor Manager with a new update entry:

1.0.0 Beta 2

Changelog
Bugfixes & Changes
  • All nodes in the Admin Control Panel are now tied to the 'Manage BB Codes and Smilies' administrator permission.
  • A bug with the editor toolbar not loading on the quick thread option (and any other ajax operation that is performed in an environment where no other editor has been initialized yet) has been taken care of. This should be fixed with XF 2.0 Beta...
Read the rest of this update entry...
 

katsulynx

Well-known member
#8
Looks like the upgrade-routine from Beta 1 installation status to Beta 2 is not triggered as expected. For now you should be able to get around this by uninstalling the addon, installing Beta 1 from the history and then upgrade to Beta 2. I'll deliver a hotfix in a few hours, after that installation should work like expected.
 

katsulynx

Well-known member
#9
The hotfix is now available for download. Please uninstall the addon and do a fresh installation with the hotfix. I don't expect it, but if you should encounter any difficulties while uninstalling, please report back @bousaid. Please note that these difficulties only arouse for fresh Beta 2 installations. If you have upgraded from Beta 1, there should be no problems.
 

Mr Lucky

Well-known member
#12
Thank you for this!

Is it possible to remove icons from out of the "Insert" menu?

e.g. I want to move the Media icon to the main toolbar, and not also have it under the insert icon
 

katsulynx

Well-known member
#15
Sounds like you're missing the caches. You know how you triggered those? Try saving all option pages and switching a font off and back on, then they should be built.