• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 IP checker not working

Chris D

XenForo developer
Staff member
#2
Does this happen when you click the user's IP address?

What value do you have set in Admin CP > Options > External Service Providers > IP Information URL (IPv4) and IP Information URL (IPv6)?
 

Chris D

XenForo developer
Staff member
#4
They are the default values.

We can't reproduce the image here so it's somewhat odd.

I can't think that any add-ons would be involved there, but I suppose it's possible.
 

Bionic Rooster

Well-known member
#5
According to their site
Data Sources and APIs
Public IP Address
Scripted access to our homepage or IP details pages are not permitted.

And it worked ok a week or so ago when I last checked a users IP. No add ons have been added before or since last xF update.
 
#10
It happens on them all that I have tried including the one you provided above.
I think I may have found the problem I'm using Firefox 44.0.2 and it won't access the IP link but I just tried Google Chrome and IE 9 and they both work fine.
FF just updated the other day so that explains ( I guess) why it's not working now when it did before.
Is there any way to go back a version in FF? Or I guess I'll have to wait till the next update to see if that fixes it.
Thanks for your help guys, much appreciated :)
 

Chris D

XenForo developer
Staff member
#11
I can't reproduce this in FF 44.0.2 either...

Do you have any browser extensions installed? Might be worth disabling them all and trying again.
 
#15
I got a response back from their support that wasn't helpful. They just said there was an hourly rate limit to prevent scrapping. Try again later. 2 hours later it still didn't work. :cry:
Back to the drawing board I guess.........:sleep:
 
#17
Their support seems to think it is some setting in my OS "it appears to be related to anti-DDoS features" I got an auto update about a week ago for Vista. Though I would think if it was OS related wouldn't it also affect Chrome and IE?
 
#18
@Chris D
Update - tech support has found the problem at their end and have rolled out an update that has fixed the problem. They did not elaborate on what the problem was (I probably wouldn't know what they were talking about LOL) but it's working now and that's the main thing :)
 

Tracy Perry

Well-known member
#20
Wonder if they are using a shared IP and the API is getting to many hits to it from that IP or if something is stripping the user agent when submitting the request?

IP Insights
IPv6 Learning Center

Data Sources and APIs

Public IP Address

Scripted access to our homepage or IP details pages are not permitted.
We provide several pages that return just the public IP address of the device making the request. You may programmatically query that server but limit queries to no more than once per five minutes and include an appropriate user agent that will allow us to contact you if needed. Requests with a blank user agent may be dropped.