• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Installation error (Server Error)

#1
Just after clicking "Begin installation", after having verified that all settings were ok, I got this message with no way to continue or go back:

Code:
Server Error
Mysqli statement execute error : Error writing file '/mysql-tmp/MLxysR5n' (Errcode: 28)

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in XenForo/Model/AdminTemplate.php at line 723
XenForo_Model_AdminTemplate->compileParsedAdminTemplate() in XenForo/Model/AdminTemplate.php at line 602
XenForo_Model_AdminTemplate->compileAllParsedAdminTemplates() in XenForo/Deferred/AdminTemplate.php at line 16
XenForo_Deferred_AdminTemplate->execute() in XenForo/Deferred/Atomic.php at line 61
XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 208
XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 331
XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 265
XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Install.php at line 221
XenForo_Install_Controller_Install->actionRunDeferred() in XenForo/FrontController.php at line 337
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /hermes/bosoraweb185/b2140/dom.teslataxime/xenForo/install/index.php at line 18
I did a search and found something looking somewhat like it. That user had solved his problem by reinstalling the package and running the install again. Also, for some weird reason my other mySQL database (one I used for the forum I'm currently upgrading to XenForo) seems to have become corrupted because of this. They don't have the same name of course.

Please advice.
 

Mike

XenForo developer
Staff member
#2
That error code is for the disk/partition being full -- specifically /mysql-tmp. Either it is actually full or it's simply too small. I'd recommend contacting your host.
 

Mike

XenForo developer
Staff member
#4
I'd go back to the beginning - you just finished creating tables so it shouldn't take more than a minute and it is a bit safer.
 

Brogan

XenForo moderator
Staff member
#6
Do a completely clean installation - drop all of the tables and run the install script again.