1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Installation Error - Include Path Issues

Discussion in 'Installation, Upgrade, and Import Support' started by GreenGel, Feb 1, 2012.

  1. GreenGel

    GreenGel Member

    I just purchased XF and set about to installing it on my server but ran into a problem. When I went to the site.com/install/ directory where all the files were located it said I needed iconv to be active to use the software.

    Probably my bad for not reading/running the requirements test script first, but still no big deal. I e-mailed my host, told them what I needed, and they were able to turn it on.

    I attempted to go back to the installation and start over and was met with a different error. Specifically:

    Fatal error: main() [function.require]: Failed opening required 'Zend/Controller/Request/Abstract.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/xxxxxxx/php') in /home/xxxxxxx/public_html/library/Zend/Controller/Request/Http.php on line 23
    I did a quick search for that error and found this thread:


    I also got back in contact with my host, explaining the new error, and inquiring whether some old setting (because it had at least loaded the installation page before, whereas with the new error it doesn't even do that) had been overwritten when iconv was turned on.

    In order to solve the problem first they attempted to manually change the paths in that file. I explained this was far from ideal. And all it did was let me open the initial page, put in the DB info, and then when I click the "configure" button at the bottom of the page get another error in a different file (the mysqli.php file in the Zend library I believe.)

    Seeing as how changing every single file is not really a good way to do things, nor is it particularly feasible even, I'm sure there must be a way to fix the issue. Unfortunately some of the items mentioned in the thread I noted above are simply beyond my understanding of where/how to go about doing them.

    For what it's worth the host also tried this, after I explained further what was in that thread the host attempted another change that did not work out they said:

    This did not fix the issue as I am simply getting the same error (I reverted the changed file done with an absolute path back to the relative path to reset everything back to original.)

    For what it's worth I have a VPS account (w/ cPanel/WHM) that I can access and my host is LiquidWeb.

    Any help would be appreciated.

    (Also, apologies for the length of the post, I just wanted to try and include as much information as I could upfront.)
  2. Mike

    Mike XenForo Developer Staff Member

    The include_path is changed automatically when XenForo runs. It sounds like that's failing. The only reason I know of where that can fail involves PHP running as an Apache module, which I doubt applies to you.

    If it requires manual include_path changes, then /home/entropy/public_html/library/ would be correct.
  3. GreenGel

    GreenGel Member

    I went in and manually edited the include_path in the php.ini file to include what you listed above, but am getting the same error.

    Assuming I am running PHP as an Apache module (not sure, is there a way to check?) is there a workaround for that as well?
  4. Mike

    Mike XenForo Developer Staff Member

    It's probably easiest at this point to submit a ticket with FTP login details and I'll see if I can figure out what's going on.
  5. GreenGel

    GreenGel Member

    Will do. Thank you for the help.
  6. DivokyMuz

    DivokyMuz Member

    Was there found a solution for this problem ?

    We have the same problem with our just bought 1.2.2 version of XF. Together with our hoster we try now for around three days to install the board and nothing works.
  7. Mike

    Mike XenForo Developer Staff Member

    This either indicates that the files weren't uploaded correctly or there's an include_path issue:
  8. DivokyMuz

    DivokyMuz Member

    I wrote this answers before to our host, lets see what he will find.

    Upload is correctly, i did it also file by file, to see that it works correctly :)
  9. DivokyMuz

    DivokyMuz Member

    Perhaps it helps other users, what was the mistak in our problem.

    Now all works properly, because the hoster put suphp on the server.

    Without this, the Confixx Managment software makes it impossible to set the include_path. Now, after the change, everything works perfect.

Share This Page