1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Installation error for latest version (1.1.3)

Discussion in 'Installation, Upgrade, and Import Support' started by kwaken, Jul 7, 2012.

  1. kwaken

    kwaken Member

    Hello,

    I am trying to install XenForo 1.1.3 on my VPS (fresh installation). I get below error:
    Server Error
    unserialize() [<a href='function.unserialize'>function.unserialize</a>]: Error at offset 0 of 1 bytes
    1. XenForo_Application::handlePhpError()
    2. unserialize() in XenForo/Model/StyleProperty.php at line 667
    3. XenForo_Model_StyleProperty->updatePropertyCacheInStyle() in XenForo/Model/StyleProperty.php at line 632
    4. XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren() in XenForo/Model/StyleProperty.php at line 2316
    5. XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2187
    6. XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2120
    7. XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/CacheRebuilder/ImportMasterData.php at line 45
    8. XenForo_CacheRebuilder_ImportMasterData->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
    9. XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/Install/Controller/Install.php at line 240
    10. XenForo_Install_Controller_Install->actionStep2b() in XenForo/FrontController.php at line 310
    11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132


    Kindly help me to fix the problem! Thanks..
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Hmm. I would like to debug that error to see what style property it is. But first I recommend simply re-uploading all of the files and running the install again. If the error persists then I can take a look if you give me FTP access.
     
  3. kwaken

    kwaken Member

    Thanks Jake.. I tried several times and same error each time :( i just send you PM with details for help.
     
  4. Slavik

    Slavik XenForo Moderator Staff Member

    What version of PHP are you using?
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    He meets the reqs. PHP 5.2.17.
     
  6. kwaken

    kwaken Member

    ****@server [~]# grep safe_mode /usr/local/lib/php.ini
    safe_mode = Off

    ****@server [~]# php -m | grep -i 'gd\|pcre\|MySQLi\|SPL\|SimpleXML\|DOM\|JSON\|iconv\|ctype'
    ctype
    dom
    gd
    iconv
    json
    mysqli
    pcre
    SimpleXML
    SPL
    -------
    ****@server [~]# php -v
    PHP 5.2.17 (cli) (built: Jun 9 2012 11:38:35)

    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
    with eAccelerator v0.9.6.1, Copyright (c) 2004-2010 eAccelerator, by eAccelerator
    with the ionCube PHP Loader v4.0.12, Copyright (c) 2002-2011, by ionCube Ltd., and
    with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies

    ****@server [~]# mysql -V
    mysql Ver 14.12 Distrib 5.0.95, for unknown-linux-gnu (x86_64) using readline 5.
     
  7. Slavik

    Slavik XenForo Moderator Staff Member


    First up. Update to at least a 5.3 extention, if not a 5.4 version of php.

    Secondly, do you realy need ionCube, zend optimizer and eAccelerator? I would drop all 3 unless you "actually" need them. For caching APC will provide you better performance over eAccelerator.
     
    Adam Howard likes this.
  8. kwaken

    kwaken Member

    Thanks Slavik but,

    If i update to 5.3 then few of my joomla sites will not work. ioncube & zend optimizer i need it for few components / scripts. Also, i think as per requirement given at XenForo, this shouldn't be a problem at all.

    Also, Jake asked me to disable eAccelerator & Zend Optimizer. This didnt solve the problem as well.
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Couple reports of this problem which Mike handled:

    http://xenforo.com/community/threads/style-problem.20540/
    http://xenforo.com/community/threads/server-error-help.28689/

    Mike's post here makes sense based on my debugging:

    I verified the correct data from the model to the db adapter, yet for some reason the serial string is written as 0.

    Mike is probably the dev who will reply to your ticket. But it looks like the solution may just be to upgrade your server software.
     
  10. Floren

    Floren Well-Known Member

    Just for the kicks, what is the memory limit you use in PHP?
    I saw the Error at offset 0 of 1 bytes associated with exhausted memory.

    This is what I use on my server:
    php_admin_value[memory_limit] = 128M
    php_admin_value[post_max_size] = 8M
    php_admin_value[upload_max_filesize] = 8M

    I also set the MySQL packet size 64M.
     
  11. EasyTarget

    EasyTarget Well-Known Member

    I had the same issue with the unserialize function. It really is a .php issue. You can work with your web hosting company and have xenforo use a different version of .php then your joomla installs. Although I would be surprised if joomla broke when moving to php 5.4 or >.
     
  12. Sadik B

    Sadik B Well-Known Member


    One of the causes of this error is an incorrect installation/compilation/configuration of APC. Can you disable APC, restart apache and check if the error persists?
     
  13. kwaken

    kwaken Member

    Problem Resolved.

    Updated PHP and MySQL to latest stable versions. If anyone faced the problem, you could try this as last option.. if none worked.

    Thanks to all who helped especially Jake! Kudos..

    @Mods - pls move this to resolved or close the thread.
     
    CyclingTribe likes this.
  14. CyclingTribe

    CyclingTribe Well-Known Member

    A happy ending - always good to see those. Congrats and I bet you're relieved to be up and running now? :D
     
  15. Slavik

    Slavik XenForo Moderator Staff Member

    Lol, I hate to say I told you so.. but...
     

Share This Page