1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Inserting an Image into thread prefixes

Discussion in 'Styling and Customization Questions' started by Rum Runner Entertainment, Sep 16, 2014.

  1. Rum Runner Entertainment

    Rum Runner Entertainment Active Member

    Is there a way to add in an image as a thread prefix?
     
  2. Digital Doctor

    Digital Doctor Well-Known Member

  3. Rum Runner Entertainment

    Rum Runner Entertainment Active Member

    I'm not quite understanding they're posts there.. hmm. So is it possible to add in a full on .png file as a prefix?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Rum Runner Entertainment

    Rum Runner Entertainment Active Member

    Alright, I understand. So you're saying that I need to add in that whole CSS to the EXTRA.CSS Template? Or just the blue and red which consist of the CTA1 and CTA2?
     
  6. Rum Runner Entertainment

    Rum Runner Entertainment Active Member

    Here is the code I have there now:

    .prefix.prefixCTA1 {
    color: @textCtrlBackground;
    background-image: url('https://forums-piratesonlinerewritten.com/data/images/fireskul.png');
    background-color: @primaryDarker;
    border-color: @primaryDark;
    background-size: 25px 25px;
    }

    a.prefixLink:hover .prefix.prefixCTA1 {
    color: red;
    background-color: yellow;
    border-color: blue;
    }

    But for some reason, the image is not showing at all. I kept everything the same, I just added in the background image url code as well as sizing codes.
     

Share This Page