1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 index.php

Discussion in 'Troubleshooting and Problems' started by isaiahv, May 12, 2014.

  1. isaiahv

    isaiahv Member

    Hi,
    I'm learning as I go, so forgive me for the rookie question. I've had my xenforo for about a month. I did a speed check the other day, and the software said that my home page goes to domain.com/index.php but should be going to domain.com.

    I am using Godaddy. Is this something easy to fix? Any help would be much appreciated. Thanks!
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    If you are not wanting to see the index.php enable friendly URL's. It requires you to use the .htaccess (the shipping htaccess.txt can usually just be renamed to .htaccess).
     
    isaiahv likes this.
  3. isaiahv

    isaiahv Member

    Thanks it worked!
     
    Tracy Perry likes this.
  4. isaiahv

    isaiahv Member

    Now it is doing this

    [​IMG]
     
  5. isaiahv

    isaiahv Member

    It always does it the first time, but when I hit refresh it goes away.
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    What http server and what exactly is in your .htaccess?
    Are you on a shared host or VPS/dedi?
     
  7. isaiahv

    isaiahv Member

    Godaddy. I'm on shared host.

    Inside the htaccess is this:

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    #</IfModule>

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Pretty sure GoDaddy uses Apache for their shared hosting servers. That should be working fine and you should not be getting any redirects unless they have something else configured via their panel.
     
  9. isaiahv

    isaiahv Member

    Where would I need to go to verify something is configured in the panel?
     
  10. Mike

    Mike XenForo Developer Staff Member

    This looks sorted now as it's loading without issue for me.
     
  11. isaiahv

    isaiahv Member

    No it's still doing it. For me it looks like what is in post #4. Then when I hit refresh it loads to the site, but always the first time it will not open.
     
  12. Jeremy P

    Jeremy P Well-Known Member

    Browsers cache redirects, try clearing your cache.
     
  13. isaiahv

    isaiahv Member

    Where do I do that? In the cpanel?
     
  14. nodle

    nodle Well-Known Member

    Ctrl+F5
     
  15. isaiahv

    isaiahv Member

    cleared the cache of my safari browser. Still haven't same issue.
     
  16. nodle

    nodle Well-Known Member

    Did you set up this site recently? Maybe all the name servers haven't updated fully yet.
     
  17. isaiahv

    isaiahv Member

    About a month ago. Issue started happening yesterday.
     
  18. Tracy Perry

    Tracy Perry Well-Known Member

    It's also working just fine for me from here with a Mac using Safari, Chrome, Firefox and Opera.
    Totally shut your Safari down and then restart it (or use another browser). It appears to be something specific to your browser/computer.
     
  19. isaiahv

    isaiahv Member

    I think you are right, as I can't duplicate the problem from other browsers.
     

Share This Page