• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Importing my Database.sql into forum

#1
Hi .
I have been building my forum content on my pc using Xaamp . I am ready to open import the database.sql file
into the forum via the cpanel file manager. I have the file already. Anyone know where to import to exactly? I don't want to screw it up. thanks
 
#3
thanks Brogan. I just imported my bluechum.sql file using phpadmin to the bluechum_mydb folder . It imported fine -but all my catagories and topics aren't showing on the forum page. Should I have just imported into bluechum_forum?
 

Brogan

XenForo moderator
Staff member
#4
You have to import into the database which is connected with your installation.

You can check that in the library/config.php file.
 
#6
HI Brogan, thanks I found the info -my db is bluechum_forum
I tried importing and get this error:

SQL query:
--
-- Dumping data for table `xf_phrase`
--
INSERT INTO `xf_phrase` (`phrase_id`, `language_id`, `title`, `phrase_text`, `global_cache`, `addon_id`, `version_id`, `version_string`) VALUES
(1, 0, 'user_field_gtalk', 'Google Talk', 1, '', 0, ''),
(2, 0, 'user_field_gtalk_desc', '', 0, '', 0, ''),
(3, 0, 'user_field_aim', 'AIM', 1, '', 0, ''),
(4, 0, 'user_field_aim_desc', '', 0, '', 0, ''),
(5, 0, 'user_field_icq', 'ICQ', 1, '', 0, ''),
(6, 0, 'user_field_icq_desc', '', 0, '', 0, ''),
(7, 0, 'user_field_skype', 'Skype', 1, '', 0, ''),
(8, 0, 'user_field_skype_desc', '', 0, '', 0, ''),
(9, 0, 'user_field_yahoo', 'Yahoo! Messenger', 1, '', 0, ''),
(10, 0, 'user_field_yahoo_desc', '', 0, '', 0, ''),
(11, 0, 'user_field_facebook', 'Facebook', 1, '', 0, ''),
(12, 0, 'user_field_facebook_desc', '', 0, '', 0, ''),
(13, 0, 'user_field_twitter', 'Twitter', 1, '', 0, ''),
(14, 0, 'user_field_twitter_desc', '', 0, '', 0, ''),
(15, 0, 'trophy_1_description', 'Post a message somewhere on the site [...]
MySQL said:

#1062 - Duplicate entry '1' for key 'PRIMARY'


Any idea on this one? thanks
 

Brogan

XenForo moderator
Staff member
#7
Sounds like you are trying to import into a database which already has content.

You will need to empty the database first.