1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Importing from VB4 with VBSEO to Latest Xen

Discussion in 'Installation, Upgrade, and Import Support' started by Donny, Mar 21, 2013.

  1. Donny

    Donny Active Member

    Hi guys,

    I've only just heard that the law suit is over (I'm late on this I know - been busy to say the least) so I'm pleased to say I'll be transferring some of my forums over to Xen now then.

    I mostly run VB4 (I know I know) with VBSEO.

    So I'm after the porting/import script. And then the script to 301 URL's properly.

    I'm going to have a play with some of the least popular forums first, make sure I can customise them and get the features the members use etc - then take the plunge with the busier forums later in the year.

    Also; can any of the common plugins for VB be ported over? So the likes system, they'd hate to use their likes. And perhaps user albums - will they port over well? Off the top of my head I can't think of the other plugins to be honest but you get the idea.

    Thanks for any and all your help.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Donny likes this.
  3. Donny

    Donny Active Member

  4. Donny

    Donny Active Member

    Hi,

    Sorry I have a bit more time now. I think I can handle that.
    I have the VBSEO likes system in use. And the post thanks plugin.

    Wondering if I can import the thanks as thanks and likes as likes somehow? They've been used differently on my forums. People tend to like posts to acknowledge a reply or thread, but thank when they're literally thankful. Not sure they'd appreciate me mixing them up to be honest.

    Anybody managed to get them both running after switching yet?

    Thanks for your help so far.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    "Post thanks" is covered by the importer.

    There is no separate import module for the vBSEO likes, but I have handled this manually for previous imports by running this query on the vB database to convert the vBSEO likes into reputation clicks:

    Code:
    INSERT INTO reputation (postid, userid, reputation, whoadded, reason, dateline)
    	(SELECT vl.l_contentid, vl.l_dest_userid, 1, vl.l_from_userid, '', vl.l_dateline
    	FROM vbseo_likes AS vl)
    ON DUPLICATE KEY UPDATE
    	postid = VALUES(postid);
    
    The importer already has a module to import reputation as likes, so this will work. But since you are modifying the source data for the purpose of the import you should take a backup first.
     
    BamaStangGuy and HenrikHansen like this.
  6. Donny

    Donny Active Member

    Cheers pal.
    So switch likes to reputation points using that code, and that'll import as likes in the new system, right?

    I hear there is a super dooper importer being worked on, is that right? Should I wait or just take the jump?
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yes.

    There is a faster import being developed by Slavik. But that is only useful for extremely large forums. The end result is the same.
     
  8. Donny

    Donny Active Member

    I have a board with about 750k posts, two others with 600k, the rest are small in comparison. Think I'd need the faster importer for the bigger few?
     
  9. Renegade

    Renegade Well-Known Member

    With 1.7 million posts and large number of PMs we were able to complete the import including rebuilding of stats in much less than 8 hours (I think it was 5). So I don't think you need the faster importer for 0.7 million posts.

    But it would be better that you do a test import and time it. Good dry run to know what can go wrong.
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Nah. The faster importer you mentioned was originally developed for a forum with 16 million posts.
     
  11. Donny

    Donny Active Member

    Cheers lads. :) Noted.
    I'll take a copy of the forums and get them running on a sample domain, upgrade those, get them running how I want them etc. Then when I'm comfy doing it with the live sites, update the backups and go for it.

    I have about 12 (possibly more) small forums to port over first so I think I'll get the hang of it.

    I'm just getting my plugin list for Xen sorted. And what plugins I can port over from VB, first.

    User albums will be one that might pee off the members. When you say they end up as threads Jake, how do you mean? Can you link me to any example?
     
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It simply creates a new forum for albums and imports all attachments from the albums as threads/posts in that forum. I don't have a real example to show you though.
     
    Donny likes this.
  13. Donny

    Donny Active Member

    Okay, just done a test import for one of the forums.
    Transfered everything over okay.

    I can't login using my original admin username and password though. Just double checked it's correct by logging into the live forum, still running VB, and I'm using the correct details for sure.

    Any clue as to what's happening here?
     
  14. Donny

    Donny Active Member

    Wait, clocked it. It's now using the admin username from the VB forum, with the password from Xen's first admin, the admin I used to set it up.
    I'm guessing members wont have this issue then which is what I was worried about.
     
  15. Donny

    Donny Active Member

    Right, ran into a little glitch I think.
    My account on the VB forum was super admin.
    I've set the permissions for the admin forum, and allowed admins and mods to see the forum, but I don't seem to be able to edit super admin usergroup.

    Any clues how to get around this one?
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

  17. Donny

    Donny Active Member

    Sorted. I had a secondary usergroup that I'd blocked from seeing the forum areas for some reason.
    Thanks Brogan.
     
  18. Donny

    Donny Active Member

    Hi,

    Ran into another small glitch.
    I'm happy with the forum settings and whatnot so changed the URL in WHM from the test URL to the live URL.
    Now I'm getting a DB error.

    Ran a search in phpMyAdmin for the old URL and it's only picking up error logs.
    I can see the boardURL line, but can't seem to edit where on that line the URL actually is. When I click edit it gives me no options.

    Any way to resolve this?
     
  19. Donny

    Donny Active Member

    Just to update, my server guy has managed to change those options in the DB. But the site is still saying there's "unexpected error in database". So just trying to find a workaround while I wait for a response here.
     
  20. mistypants

    mistypants Well-Known Member

    Is it just a white page with text saying that? If you right click and View Source you can usually get more details.
     
    Jake Bunce likes this.

Share This Page