• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Importing from VB4.2.1 progress

#1
So here i am,

I bought the license, installed Xenforo, copied my database to a tmp one and now importing the data.

Just a few notes, i imported the forums and they are missing almost half the data, i will continue the import till the end just to see.

Another note is that importing the users (22k) is taking a lot of time, i started the import almost 3 hours ago and i am still at 15%.

I will update the thread with more details and the progress as i go.
 
#2
Ah wait, i just noticed that the forums has been imported but there is a permission issue.

As guest, i can see them all, however as administrator, i cannot.

Weird.
 
#3
is it normal that importing the users would need a total of around 11 to 12 hours ? every one percent is taking between 6 and 8 minutes to complete.

cc: @Brogan;
 

Brogan

XenForo moderator
Staff member
#4
It depends on various factors related to the size of your installation and the server specification and configuration.

This is why I stated that if downtime is important to you, you may want to consider a third party importer, which by all accounts is much faster.
 
#5
It depends on various factors related to the size of your installation and the server specification and configuration.

This is why I stated that if downtime is important to you, you may want to consider a third party importer, which by all accounts is much faster.
Well my forum is online now. I am just testing the import. I will stop the current import, do a fresh install and check out the 3rd party importer
 

Brogan

XenForo moderator
Staff member
#6
Yes, I appreciate it's a test import.

When you do it for real though, essentially your site will be unavailable for posting for the duration of the import.

Well, to clarify, members will still be able to use the vB site (if you do the import from a backup) but any content posted once the import has started won't make it into the new site.
 

Mike

XenForo developer
Staff member
#7
That does seem slow. If you chose the option to search for Gravatars, that will change the speed very significantly; if speed is a concern, you shouldn't enable that.

That said, there is a lot of variation based on server configuration. Notably, you need to make sure MySQL is tuned for InnoDB. If you haven't used that before, you probably don't have any tuning around it.