1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Importing from VB 4.2.3

Discussion in 'Installation, Upgrade, and Import Support' started by Snook, Jul 27, 2016.

  1. Snook

    Snook New Member

    Brand new XenForo user here; we were doing a test run of Importing from VB 4.2.3 and all was going well until we got to the stage "Import Content Tags" then we get hit by an Error:

    Server Error
    Mysqli statement execute error : Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='
    Zend_Db_Statement_Mysqli->_execute() in C:\inetpub\wwwroot\home-xen\library\Zend\Db\Statement.php at line 297
    Zend_Db_Statement->execute() in C:\inetpub\wwwroot\home-xen\library\Zend\Db\Adapter\Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in C:\inetpub\wwwroot\home-xen\library\Zend\Db\Adapter\Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in C:\inetpub\wwwroot\home-xen\library\XenForo\Importer\vBulletin4x.php at line 213
    XenForo_Importer_vBulletin4x->stepContentTags() in C:\inetpub\wwwroot\home-xen\library\XenForo\Importer\Abstract.php at line 124
    XenForo_Importer_Abstract->runStep() in C:\inetpub\wwwroot\home-xen\library\XenForo\ControllerAdmin\Import.php at line 189
    XenForo_ControllerAdmin_Import->_runStep() in C:\inetpub\wwwroot\home-xen\library\XenForo\ControllerAdmin\Import.php at line 137
    XenForo_ControllerAdmin_Import->actionImport() in C:\inetpub\wwwroot\home-xen\library\XenForo\FrontController.php at line 351
    XenForo_FrontController->dispatch() in C:\inetpub\wwwroot\home-xen\library\XenForo\FrontController.php at line 134
    XenForo_FrontController->run() in C:\inetpub\wwwroot\home-xen\admin.php at line 13
    We thought it just be a case of editing all the Bulletin Tables from latin1_swedish to general_ci but we can't get the damn error to clear!

    Everytime we go back into the Importer to Resume the error re-appears.
    We're not sure if its stuck from before; or if it actually 'bothers' trying again. the GUI isn't clear :(

    Please help. This is a bog standard vBulletin 4.2.3 import (nothing special). It took hours to get all the users and threads in so we don't fancy starting from scratch.
  2. Mike

    Mike XenForo Developer Staff Member

    It looks to me like your source DB is inconsistent. I have responded to your ticket to get more details though.
  3. InsaneNutter

    InsaneNutter New Member

    For anyone who Google's this, the suggestion by the Xenforo staff to add the flowing to the my.ini file, at the end of the [mysqld] section worked for us.

    Claudio likes this.

Share This Page