1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Image attachment indexing in Google

Discussion in 'XenForo Questions and Support' started by TheBigK, Dec 9, 2013.

  1. TheBigK

    TheBigK Well-Known Member

    So we let our guests view our images. My concern is that Google bots aren't indexing images. It could be because the image attachment url ends up in a number and not in an extension.

    Example: URL/attachments/my-super-image-jpg.34667/

    I think this confuses Google. Especially with Google News; they say the image URLs should end in image extension (aka .jpg , .png)

    Is there any way to get our images attachments indexed in Google?
     
  2. BamaStangGuy

    BamaStangGuy Well-Known Member

  3. TheBigK

    TheBigK Well-Known Member

    Boh! I must have been out of my mind. I used the standard xenforo robots.txt. But - are all the images on your board indexed by Google?
     
  4. BamaStangGuy

    BamaStangGuy Well-Known Member

  5. TheBigK

    TheBigK Well-Known Member

    We're serving all our attachments from a subdomain mapped to CDN. I hope that won't be a problem.
     
  6. BamaStangGuy

    BamaStangGuy Well-Known Member

    I stopped using a CDN. Wasn't worth it for me in the end to keep paying for that. Especially after moving to nginx.
     
  7. TheBigK

    TheBigK Well-Known Member

    We use Amazon. Very light on credit card. We're using LiteSpeed and it works wonders.
     

Share This Page