1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MG 1.1 http 413 error after uploading video

Discussion in 'Media Gallery Support' started by CrispinP, Jun 26, 2016.

  1. CrispinP

    CrispinP Active Member

    Hi folks,

    I am getting a http 413 error when I upload a video.

    Error in Chrome console is:
    Failed to load resource: the server responded with a status of 413 ()

    The video is 168MB, my php is set to 2048M on both post_max_size and upload_max_filesize

    post_max_size 2048M 2048M
    upload_max_filesize 2048M 2048M

    phpinfo confirms that they're set.

    What else could be causing this?
    Server has plenty space, 64GB RAM.

    php memory_limit 256M 256M
    The way I understand it that is ok?

    thanks
    Crispin
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Does XF itself give you an error in an overlay? If so what is it? What is the full output of the console? Usually it would indicate which resource failed to load. You can screenshot the console if it helps.

    Exactly at which point do you get the error?
     
  3. Mike

    Mike XenForo Developer Staff Member

  4. CrispinP

    CrispinP Active Member

    @Chris D
    All I get from XF is the overlay saying something went wrong. See below

    It gets all the way to the end (as confirmed in the console bytes-sent) and then dies.

    I should have mentioned - I am using the HTML upload resource. Might that be an issue?


    @Mike
    That's unfortunate about CF. I see on their site I the free option is limited to 100MB. Even the business package, which is $200 a month, only supports 200 which is rubbish :( https://support.cloudflare.com/hc/e...-can-I-change-the-client-maximum-upload-size-

    However, the test I have just done "bypasses" CF and resolves directly to the server. I'll read the other bits you posted and see if that helps.

    thanks,
    C

    upload_2016-6-26_13-18-5.png

    upload_2016-6-26_13-17-26.png
     
  5. Mike

    Mike XenForo Developer Staff Member

    You may need to confirm specifically what is being returned by the server. You can likely see this in the network tab of the developer tools.

    I suspect, if you've taken CF out of the equation, there are web server limits that are getting in the way (such as the one I referenced previously).
     
  6. CrispinP

    CrispinP Active Member

    ok, quick update to this..

    There were two issues I found. After looking in the apache error log I found this: (Hopefully this helps someone else)

    Code:
    mod_fcgid: HTTP request length 134218518 (so far) exceeds MaxRequestLen (134217728)
    
    So a quick fix for that by putting the following in the apache conf
    Code:
    FcgidMaxRequestLen 1342177280
    
    and it worked perfectly (for 60 seconds :( )

    A quick change then to the php settings

    Code:
    max_execution_time 600
    max_input_time 600
    

    Now, all I get is a nice clean:
    upload_2016-6-27_22-26-3.png

    That, I suspect, is a XF setting somewhere. Odd thing is, I have no limits set in the RM video options. This file I uploaded was 380MB. Might I be missing a setting somewhere?


    CloudFlare:
    This is a no go :( The only way to get around it is to stream from and upload to a sub-domain. Don't suppose anything like that is supported in XF?
     
  7. Chris D

    Chris D XenForo Developer Staff Member

    RM or MG?

    upload_2016-6-27_22-36-28.png

    If that option is checked then the maximum file size value comes from there.

    If that option is not checked then the max file size comes from the permission system so you would need to investigate that by looking at Analyze Permissions for the affected user/s.
     
    CrispinP likes this.
  8. CrispinP

    CrispinP Active Member

    Spot on - it was (default?) 100MB for registered users.

    Thanks for the help.

    Any chance of the sub-domain for uploads and downloads? (grasping at straws I know...)
     
  9. Chris D

    Chris D XenForo Developer Staff Member

    Unfortunately not.
     
    CrispinP likes this.

Share This Page