• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 How to set up User Group Promotions properly?

ibrian

Well-known member
#1
I'm having a slight problem with my user group promotions:

1. I have the basic membership of "Registered".

2. I have a couple of private boards accessed by "Senior Members" who have more than 100 posts.

However, when I set up a user group promotion, it only provides the option to "Add User to User Groups" rather than 'change primary user group'.

My problem is that running the promotion, by updating the User Group cache, simply promotes from "Registered Member" to "Registered Member + Senior Member (secondary user group) ". And the latter cannot access the private areas.

Could someone please advise how to promote members from their primary user group?

If this isn't possible, what steps do I need to take to ensure those with the "Senior Member" as an additional usergroup can access the private areas? I recall I struggled with the permissions system after importing!

EDIT: Board permissions for the private areas are:

Registered Members: revoke permissions
Senior Members - inherit
 
Last edited:

Martok

Well-known member
#2
Promotions add to secondary user groups, they don't change primary groups. Primary should always be Registered.

It's likely your promotion isn't working because you have set permissions in Registered to Never. You shouldn't use Never as it can't be overridden. You should use Not Set (No).
 

Martok

Well-known member
#3
Also, the nodes for Senior members only should be set as private nodes.In the node permissions tgern set the Seniors group View permission to Allow.
 

Martok

Well-known member
#4
EDIT: Board permissions for the private areas are:

Registered Members: revoke permissions
Senior Members - inherit
That's your problem. As I said above, set the node to private. Then set Registered to Inherit and Senior to Allow for view permissions. Everything else can be left as default four node permissions.
 

Brogan

XenForo moderator
Staff member
#5

Martok

Well-known member
#6
As Martok has stated, there are two methods for setting up private nodes:

1. Set the node as private
2. Allow the view node permission for the 'Senior' user group.

or

2. Revoke the view node permission for the Registered user group
3. Allow the view node permission for the 'Senior' user group.

Also, this guide may be of some help: http://xenforo.com/community/resources/implementing-permissions-across-multiple-user-groups.358/
Thanks, I always forget to mention the second one as the first seems easier to grasp (to me at least). :)
 

ibrian

Well-known member
#7
That's your problem. As I said above, set the node to private. Then set Registered to Inherit and Senior to Allow for view permissions. Everything else can be left as default four node permissions.
Cheers, Martok - that looks like it solved it. :)

Thanks for the reply, too, Brogan. :)