1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum is for release discussion only. Discussions that do not relate specifically to the resource release should be discussed in another, more appropriate forum.
    Dismiss Notice
  3. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

How to Remove "Sign Up Now" Button on Disabled Registration

Discussion in 'Template Modifications [Archive]' started by James, Mar 13, 2011.

  1. James

    James Well-Known Member

    When registration is disabled we really don't want to be encouraging guests to sign up, so here's a quick way of showing an alternative message.

    Open up sidebar_visitor_panel
    Find:
    Code:
    <div class="section loginButton">
    	<div class="secondaryContent">
    		<label for="LoginControl" id="SignupButton"><a href="{xen:link login}" class="inner">{xen:phrase sign_up_now}</a></label>
    	</div>
    </div>
    
    Replace:
    Code:
    <div class="section loginButton">
        <div class="secondaryContent">
            <xen:if is="{$xenOptions.registrationSetup.enabled}">
                <label for="LoginControl" id="SignupButton"><a href="{xen:link login}" class="inner">{xen:phrase sign_up_now}</a></label>
            <xen:else />
                <p class="importantMessage">{xen:phrase new_registrations_currently_not_being_accepted}</p>
            </xen:if>
        </div>
    </div>
    
    This basically checks if registration is disabled, and if it is it will display the message New registrations are currently not being accepted.. This is default from the phrase system.

    Screenshot:
    Capture.PNG
     
    Tilki├čey and Nasr like this.
  2. Vincent

    Vincent Well-Known Member

    Isn't this a default xenForo option now?

    If not, it should be.
     
  3. James

    James Well-Known Member

    I think it was, then it was accidentally overwritten. I posted it as a quick fix until the next update.
     
    Vincent likes this.

Share This Page