• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Hiding Userfield Elements

#1
SOLVED thanks to @Matt C. Replace "customfieldID" with the ID of your custom user field if you'd like to make these changes to your site:

Hide usertitle:
Now for your first question, you can add these to extra.css to hide the titles.
Code:
label[for="ctrl_custom_field_customfieldID"], label[for="ctrl_custom_field_customfieldID"], label[for="ctrl_custom_field_customfieldID"] { display: none; }
Hide userfield:
For your second question, there isn't really an option for this, so you'll have to use CSS. You can add this to the extra.css of the style which doesn't utilize "Node Images."
Code:
.customFieldEditcustomfieldID { display: none; }
Hi! I have a couple of (hopefully quick) questions.

1. How can I hide the title of a userfield (these)?

2. How can I hide a userfield for certain styles only? For example, hiding the "Node Images" field from a separate style that doesn't utilize this.

https://lakevalor.net
 
Last edited:

Matt C.

Active member
#2
Hi! I have a couple of (hopefully quick) questions.

1. How can I hide the title of a userfield (these)?

2. How can I hide a userfield for certain styles only? For example, hiding the "Node Images" field from a separate style that doesn't utilize this.

Thanks so much!

https://lakevalor.net
First off, I love your site's theme. (y) I registered on your site and used the element inspector in chrome to get the values below.

Now for your first question, you can add these to extra.css to hide the titles.
Code:
label[for="ctrl_custom_field_avatarshape"], label[for="ctrl_custom_field_glows"], label[for="ctrl_custom_field_nodeimages"] { display: none; }

For your second question, there isn't really an option for this, so you'll have to use CSS. You can add this to the extra.css of the style which doesn't utilize "Node Images."
Code:
.customFieldEditnodeimages { display: none; }
There you go! :)
 
Last edited:
#3
First off, I love your site's theme. (y) I registered on your site and used the element inspector in chrome to get the values below.

Now for your first question, you can add these to extra.css to hide the titles.
Code:
label[for="ctrl_custom_field_avatarshape"] { display: none; }
label[for="ctrl_custom_field_glows"] { display: none; }
label[for="ctrl_custom_field_nodeimages"] { display: none; }

For your second question, there isn't really an option for this, so you'll have to use CSS. You can add this to the extra.css of the style which doesn't utilize "Node Images."
Code:
.customFieldEditnodeimages { display: none; }
There you go! :)
Thank you very much! :) We're using UI.X with a lot of customization.

Hiding the titles didn't work unfortunately, but hiding the field did.
 

Matt C.

Active member
#4
Thank you very much! :) We're using UI.X with a lot of customization.

Hiding the titles didn't work unfortunately, but hiding the field did.
That's odd, since it worked in the element inspector.

Try this and see if this works
Code:
label[for="ctrl_custom_field_avatarshape"] { display: none !important; }
label[for="ctrl_custom_field_glows"] { display: none !important; }
label[for="ctrl_custom_field_nodeimages"] { display: none !important; }
I don't have access to a laptop at the moment, so I can't test it right now.
 
#5
That's odd, since it worked in the element inspector.

Try this and see if this works
Code:
label[for="ctrl_custom_field_avatarshape"] { display: none !important; }
label[for="ctrl_custom_field_glows"] { display: none !important; }
label[for="ctrl_custom_field_nodeimages"] { display: none !important; }
I don't have access to a laptop at the moment, so I can't test it right now.
EDIT: It worked - I just messed something up in CSS.

Huge thanks to Matt. He fixed this and reorganized my extra.css in a way that actually makes sense (it was a mess before). Great guy!
 
Last edited: