1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Header Thumbs 1.8

Adds three small images to your header. Images change every 10 minutes. Images link back to post.

  1. AndyB

    AndyB Well-Known Member

    AndyB submitted a new resource:

    Header Thumbs - Adds three small images to your header.

    Read more about this resource...
     
    santamo likes this.
  2. santamo

    santamo Active Member

  3. Heatsink

    Heatsink Member

    Hi many thanks another great addon :)
    In the Options it was taking the settings and i double checked my paths but all I got was your default images and Links
    Couldnt find them and then saw them in the XML install

    So I ended up editing the XML install file to update the paths and image folders and then doing an upgrade
     
  4. oloman

    oloman Active Member

    Hi

    The images in my folder are updated after the cron, but pictures are staying the same (moto)
     
  5. oO5 Dynasty

    oO5 Dynasty Active Member

    is their a way to do one banner on the main page.
     
    51463 likes this.
  6. WCFA

    WCFA Active Member

    Installed just fine, but only rotates pictures from your website. Does not look at the forum number.
    I must be doing something wrong.
     
  7. AndyB

    AndyB Well-Known Member

  8. CNK

    CNK Active Member

  9. macroforum

    macroforum Active Member

    Thanks @AndyB for this useful addon, but i have this error:
    Code:
    Server Error
    
    file_get_contents(/home/fotograf/web/XXXXXXXXXXXXXXXXXXXX/public_html/internal_data/attachments/14/14676-5580f1edeb347555f7b71129148b7d00.data): failed to open stream: No such file or directory
    
    XenForo_Application::handlePhpError()
    file_get_contents() in Andy/HeaderThumbs/CronEntry/HeaderThumbs.php at line 74
    Andy_HeaderThumbs_CronEntry_HeaderThumbs::runHeaderThumbs()
    call_user_func() in XenForo/Model/Cron.php at line 356
    XenForo_Model_Cron->runEntry() in XenForo/ControllerAdmin/Cron.php at line 213
    XenForo_ControllerAdmin_Cron->actionRun() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/fotograf/web/XXXXXXXXXXXXXXXXX/public_html/admin.php at line 13
    I'm using [bd] Attachment storage addon.
    Thanks
     
  10. AndyB

    AndyB Well-Known Member

  11. abbychase

    abbychase Active Member

    Possible to change it from posts to XenGallery for the source of images?
     
    sinucello likes this.
  12. t956gon

    t956gon Member

    Hi...sorry could be me being thick, but what do these files need to be... or are they empty folders...thanks

    Image and text file preparation:

    In the folder specified in Options (Thumb Path), create six files and chmod each one to 777. The file names need to be:

    headerthumbs0.jpg
    headerthumbs0.txt
    headerthumbs1.jpg
    headerthumbs1.txt
    headerthumbs2.jpg
    headerthumbs2.txt
     
  13. behnam

    behnam Member

    I installed this plugin as described but it does not work and the images in my website is broken.... and I have these server errors in server's errors :

    Code:
    Server Error
    
    file_put_contents() [function.file-put-contents]: Only 0 of 44 bytes written, possibly out of free disk space
    
        XenForo_Application::handlePhpError()
        file_put_contents() in Andy/HeaderThumbs/CronEntry/HeaderThumbs.php at line 117
        Andy_HeaderThumbs_CronEntry_HeaderThumbs::runHeaderThumbs()
        call_user_func() in XenForo/Model/Cron.php at line 356
        XenForo_Model_Cron->runEntry() in XenForo/ControllerAdmin/Cron.php at line 213
        XenForo_ControllerAdmin_Cron->actionRun() in XenForo/FrontController.php at line 347
        XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
        XenForo_FrontController->run() in /home/cozmbeoi/public_html/admin.php at line 13
    
     
  14. karll

    karll Well-Known Member

    Thank you, Andy, for another very useful add-on!

    I've just installed it on my site. There is one thing that doesn't seem to work all the time (but sometimes it does work). When I click on a thumbnail, I'm taken to the correct thread, but not the correct page.

    Also, one thing that could be improved - and hopefully it's an easy fix: If a user has a page open with a certain set of thumbs displayed, and then wait beyond the 10 minutes before they click on one of the images, they are taken to the wrong thread. It would probably be better if the link associated with each thumb was generated when the page is rendered instead of when they click on the thumb. (I hope that makes sense.)
     
  15. AndyB

    AndyB Well-Known Member

    karll and behnam like this.
  16. karll

    karll Well-Known Member

    A couple of ideas for possible improvements:
    • When hovering over each thumb, the title of the thread could be displayed.
    • Keep the last x set of thumbs that were generated, and add some arrows so the user can go back to look at the previously generated thumb sets.
    • Improve the styling / layout a bit. I think it might look better if the same amount of horizontal space was allocated for each thumb, even for images that are in "portrait mode". Some kind of "frame" around the set of thumbs might improve the visual appeal, as well.
     
  17. karll

    karll Well-Known Member

    One of my members reports that thumbnails from images in deleted posts are being displayed.
     
  18. AndyB

    AndyB Well-Known Member

  19. Axel B

    Axel B Well-Known Member

    Hi @AndyB ,
    I installed your addon as per your instructions. @MattW helped out doing the magic stuff on the server. ImageMagick and Exec() is working.
    Unfortunately nothing shows up in the header :(
    I checked if the issue is caused by the theme I'm using, but no thumbs show up in the default Xenforo theme either.

    The only thing I can think of is that the images need to be on my server? Right now 99% of the images are links to things like Dropbox.

    Any help would be highly appreciated! Thanks in advance :)

    -------
    Update: Added a couple of nodes which contain images as attachment. The addon works on the default skin. Unfortunately it does not work on the Flat Awsome shin :(

    Will check with the creator of that forum if he can help out ;)
     
    Last edited: Feb 21, 2015
  20. otto

    otto Well-Known Member

    As Andy in the overview says:
    Linked images are not attachments. But you can use an other add-on from Andy (Convert All) to convert all linked images to attachments. But then you will have all images back on your own server... ;)
     

Share This Page