• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Google+ Auth Issue

#1
Hi guys, loving 1.3 so far.

I'm having an issue with the G+ integration though - works fine from the login/signup pages, but when I try to link my Google account with my forum account from /forum/account/external-accounts



Code:
Google

Error:origin_mismatch

Request Details

scope=https://www.googleapis.com/auth/plus.login https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/plus.moments.write https://www.googleapis.com/auth/plus.me https://www.googleapis.com/auth/plus.profile.agerange.read https://www.googleapis.com/auth/plus.profile.language.read https://www.googleapis.com/auth/plus.circles.members.read
redirect_uri=postmessage
origin=http://www.diabetes.co.uk
state=505791056|0.1291697424
display=page
request_visible_actions=http://schemas.google.com/AddActivity
hl=en-GB
cookie_policy_enforce=false
response_type=code token id_token gsession
access_type=offline
cookie_policy=single_host_origin
proxy=oauth2relay431855036
include_granted_scopes=true
client_id=393612286027-8mkgnghp72loth1tmjc587m2qgm3taa5.apps.googleusercontent.com
 

Mike

XenForo developer
Staff member
#2
What is your origin set to in Google? I get this error when attempting to register with Google on all of your pages.
 
#3
Gah, looks like I've just set this one up wrong then! Might as well move the thread out of bug reports *facepalm*

In the OAuth section, the origin had somehow defaulted to https rather than http for some reason. Looks like it's working alright now though. Sorry about that >_<