1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 gifs not animated when viewing my website...

Discussion in 'Troubleshooting and Problems' started by Sean B., Feb 5, 2014.

  1. Sean B.

    Sean B. Active Member

    so I have have a gif as my avatar on my site but its not animated like its supposed to be, I'm able to get it to animate on other XF sites except mine, it only seems to be gifs as other images on my site are just fine.


    my site link is...www.kh-flare.net

    if you take a look at my profile which you can view through this link you'll notice my avatar looks like a normal image, but its not its a animated gif made from a video, I dunno wut is causing that to occur but can someone help me and tell me how to fix this issue with my avatar?

    also it seems to only be an issue in certain areas of the forum, but on my profile for whatever reason it's working like it should, but I want it to work in all areas of the forum, so any help would be very appreciated.

    thank you.
     
  2. Amaury

    Amaury Well-Known Member

    Sean forgot to mention that it's on Google Chrome, which I can confirm myself. It's not an issue on Mozilla Firefox.
     
  3. Sean B.

    Sean B. Active Member

    ty amaury for pointing that out, sorry I forgot to mention that.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    The issue you're talking about can be seen in Chrome and Firefox. Are you saying that the avatar is animated everywhere on Firefox? Because I can't confirm that.

    Anyway, the cause for this is most likely your choice of image processor.

    In Admin CP > Options > Attachment Options you should enable "ImageMagick" as the image processor. This may not be installed on your server. If it isn't, you will need to do so or ask your host to.

    If it is enabled already, and still the avatars are not animated, then I have seen this issue before. And all it boiled down to was a bug version of Image Magick. Either upgrading or downgrading ImageMagick actually resolved the issue.

    By default XenForo uses GD as its image processor. This is quite basic and it doesn't support things like processing animated images.
     
    rootsxrocks likes this.
  5. Amaury

    Amaury Well-Known Member

    Hm. That's odd.

    On Mozilla Firefox, I can see the issue on the default style, but not on our custom style. Maybe it's because our message avatars are bigger?
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    Then original L size image will be animated because it hasn't been resized. Any versions of the avatar that have been resized will lose their animation unless you use ImageMagick (once enabled by the way the avatar will need to be uploaded again before it will appear animated at all sizes).

    So yeah possibly if you have modified a style to only show L avatars then they may appear animated.

    Ultimately best solution is to use Imagick.
     
  7. Amaury

    Amaury Well-Known Member

    All members' avatars or only those that are animated?

    Also, I just took a look, and we are using "PHP built-in GD image library."
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    Yeah so get Image Magick installed.

    After installing that, your existing avatars will be unchanged. You'd just need to re-upload avatars if you want them to be animated.
     
    rootsxrocks and Amaury like this.
  9. Amaury

    Amaury Well-Known Member

    We have the option, but how do we tell if it's already installed or not?

    "ImageMagick PECL Extension"
     
  10. Mike

    Mike XenForo Developer Staff Member

    If the option is selectable, you have it.
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    It will only let you select it if it detects it is installed.

    EDIT: [​IMG]
     
    Steve F and Amaury like this.
  12. Amaury

    Amaury Well-Known Member

    Thanks, guys.

    If it's installed, it's strange that this message is shown under it: "You must have the imagick PECL extension installed."
     
  13. Chris D

    Chris D XenForo Developer Staff Member

    Why is that strange?
     
  14. Amaury

    Amaury Well-Known Member

    Oh, derp. We don't have it. The option is there, but it's non-selectable. That would be why.
     
  15. Chris D

    Chris D XenForo Developer Staff Member

    That's what we said... But for the record that message remains unchanged whether it is installed or not.
     
    Amaury likes this.
  16. Amaury

    Amaury Well-Known Member

    Thanks, Chris. I read your guys' replies wrong.

    I personally think that's a bit misleading once installed, but meh.
     
  17. rootsxrocks

    rootsxrocks Active Member

    I had this problem and ImageMagick fixed it but when WHM updated to 11.4 I had to reinstall ImageMagick. and TBH i still haven't got it tuned right any gif over 2 M is iffy whether it will convert or become a jpg
     
  18. Sean B.

    Sean B. Active Member

    Sorry for replying so late, have a lot of **** going on...anyway ty so much chris will install imagic.=)
     
  19. Sean B.

    Sean B. Active Member

    could you link me to the Imagic addon? because I can't find it in search but I don't feel like looking through page after page just to find it either.=/
     
  20. Brogan

    Brogan XenForo Moderator Staff Member

    It's not an add-on, you need to install it on your server.
     
    rootsxrocks likes this.

Share This Page