1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting ready to convert from vB4 to xF

Discussion in 'Installation, Upgrade, and Import Support' started by AndyB, Mar 22, 2013.

  1. AndyB

    AndyB Well-Known Member

    I have the importer folders uploaded. In preparation of importing I went to the install page and get this message:

    pic001.jpg

    1) What happens if I click the "Click here" link?
    2) What does it mean to "Rebuild Master Data?

    I assume the best thing to do would be to delete the current MySQL database and create a new one with the same name? Is this correct?
     
  2. Nasr

    Nasr Well-Known Member

    The click here will do a fresh install where you must delete everything in the database.
    The Rebuild Master Data will only rebuild the cache for all the templates and phrases etc.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Why are you loading the install page to do an import?

    You do it from the ACP.
     
  4. AndyB

    AndyB Well-Known Member

    Thank you, Nasr.

    Perfect, the "Click here" option saves me the the effort of deleting the current database and creating a new one.
     
  5. AndyB

    AndyB Well-Known Member

    Hi Brogan,

    I assumed that I want to start with a completely empty database. Does the importer empty the database as the first step?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. AndyB

    AndyB Well-Known Member

    I think that's the best idea.
     
  8. AndyB

    AndyB Well-Known Member

    I deleted my xF database and created a new one. I navigated to the /install/ folder and get the following error:

    pic001.jpg

    What am I doing wrong?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    The install_lock.php file is still in place; delete it from the internal_data directory.
     
  10. AndyB

    AndyB Well-Known Member

    Thank you, Brogran. I was hoping it would be some thing simple like that. It would have been so much better if the error message would indicate this issue.
     
  11. AndyB

    AndyB Well-Known Member

    Unfortunately deleting the install_lock.php on the server appears to not be the only problem. I still get the same error message.
     
  12. AndyB

    AndyB Well-Known Member

    Found the problem. When I navigated to the /install URL, Firefox put in the trailing upgrade to the path. I needed to delete that part in the URL path and now I'm good to go.
     
    CyclingTribe likes this.
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Edit: Good to hear.
     
  14. AndyB

    AndyB Well-Known Member

    Currently my primary URL is in a folder called xenforo. Ultimately it will be in the "forums" folder. My question is can I specify xenforo for now and change it easily in the ACP later?

    pic001.jpg
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Nasr likes this.
  16. Nasr

    Nasr Well-Known Member

    Yes.
     
  17. AndyB

    AndyB Well-Known Member

    Thank you, Brogan and Nasr.
     
  18. AndyB

    AndyB Well-Known Member

    I installed the importer vbulletin4-importer-3.6b2 successfully. But when I try to run the Import External Data link, I get the following error message:

    Fatal error: Class 'XenForo_Importer_Abstract' not found in /path/to_my_site/www/xenforo/library/XenForo/Importer/vBulletin.php on line 4
     
  19. Nasr

    Nasr Well-Known Member

    Make sure you've uploaded all the files correctly and to the correct directory.
     
  20. AndyB

    AndyB Well-Known Member

    I'll double check the folders now.
     

Share This Page