1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Getting a lot of authorization errors

Discussion in 'XenForo Questions and Support' started by Renegade, Mar 28, 2013.

  1. Renegade

    Renegade Well-Known Member

    I am getting a lot of 403 errors on the section which is not visible to unregistered/unconfirmed. How is google crawler even able to see the list of threads in that section?

    Does it get crawled from the RSS feeds. How do I disable that? I have news feed disabled but still the RSS icon shows up.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Search engines are also guests. If guests can't view a particular section then neither can search engines.

    The outgoing feeds also obey permissions.

    Maybe Google got the thread links from an Adsense banner on the page. There are many possibilities. Merely having the link isn't cause for concern. Test it yourself when you are logged out to make sure you can't access the thread.
     
  3. Renegade

    Renegade Well-Known Member

    That I cannot. Could be the adsense banner then. However this has started coming up only after the migration to XF. The count used to be zero on VB.
     
  4. Mike

    Mike XenForo Developer Staff Member

    I don't know if vB sent 403 headers like XF does (which is the correct header to sent).
     
  5. Renegade

    Renegade Well-Known Member

    Quite possible.. I remember the devs at IPB also pointing out something similar on their forums.
     
  6. Renegade

    Renegade Well-Known Member

    On a related note. I have got several 503 error but all the pages are thread view order related (or xentrader pages). I don't think this qualifies as a 503 error.

     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Where are those 503 errors logged? Do you get a 503 yourself when visiting those pages?

    XenForo does return a 503 in some situations, such as when the board is turned off or in the middle of an upgrade. XenForo always displays a readable error with a 503 to explain the reason. Or maybe your host or server person was performing temporary maintenance.
     
  8. Renegade

    Renegade Well-Known Member

    In google webmaster tools. If it were due to the board turned off or server maintenance then I would have got some other pages in the error as well. The error count is 1.2K and all pages are ordering or xentrader profile related.
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can look in the logs on the server itself to try to find a record of these requests. But if those pages are working fine right now and you are unable to reproduce the error then you may not wish to spend time on this.
     
  10. Renegade

    Renegade Well-Known Member

    The server error logs at xf admin side is blank. Which is inline with my expectation that there is no server issue. Frankly I do not care if those links do not get crawled but perhaps the error being returned by XF is not accurate.
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    We only have a status code. The error might be from your web server and not XenForo.
     

Share This Page