• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Friendly URLs not working

b3nji

New member
#1
Hello,
I'm getting the following 404 error with Friendly URLs enabled:

Not Found
The requested URL /forums/main-forum.2/ was not found on this server.
Apache/2.2.14 (Ubuntu) Server at xxxxxxxxx.com Port 80

url: http://bit.ly/wxDbaB

.htaccess file (located in correct directory as far as i can tell):

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Jake Bunce

XenForo moderator
Staff member
#2
.htaccess file (located in correct directory as far as i can tell):
The error you are getting indicates otherwise. When you upload the files there is a file named htaccess.txt. This needs to be renamed to .htaccess once on the server.
 

Jake Bunce

XenForo moderator
Staff member
#4
Maybe your server doesn't have mod_rewrite installed? It's either that or there is a problem with the .htaccess file (doesn't exist, named incorrectly, etc).
 

Mike

XenForo developer
Staff member
#5
Or that the .htaccess is being ignored (AllowOverride is not set correctly in the Apache config). That's the out of the box setting for Apache.