1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Friendly URL Problem New Install

Discussion in 'Troubleshooting and Problems' started by Davyc, May 14, 2014.

  1. Davyc

    Davyc Well-Known Member

    Hi Guys

    Just installed XF 1.3 and activated the friendly URLs but I've hit a problem

    This is what the URL should be:

    http://www.thespiritualway.co.uk/forums/main-forum.2/

    But this is what's happening:

    http://www.thespiritualway.co.uk/forums/forums/main-forum.2/

    Which generates page not found errors

    I adjusted the .htaccess file to this:

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    #</IfModule>
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /forums
    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>

    But no joy. The forum is in a sub-folder titled forums so is this causing the problem.

    Any help would be appreciated. BTW I'm on a 1and1 unlimited shared hosting platform
     
  2. Mike

    Mike XenForo Developer Staff Member

    Are you sure it's .htaccess (not htaccess.txt)? It looks like the .htaccess isn't being picked up.
     
  3. Davyc

    Davyc Well-Known Member

    Yep it's definitely .htaccess - I have this in the same folder as all the other files; should this be in the root?

    Edit:

    How bizarre - I deleted the .htaccess file and renamed the htaccess.txt file, changed the redirectbase to forums and it's working. However the URLS are still showing /forums/forums - is that the way it's supposed to be?
     
    Last edited: May 14, 2014
  4. Brogan

    Brogan XenForo Moderator Staff Member

    You have it installed in the /forums directory, so yes.

    Unless you plan to install something at the root (http://www.thespiritualway.co.uk/) why not just move the installation to there?
     
  5. Davyc

    Davyc Well-Known Member

    Thanks Mike/Brogan - I am planning to install something into the root, but I may just change my mind on that subject lol.

    As of now it's all good, so thanks again for prompt responses.
     

Share This Page