1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug "Forgot Password" link not working in IE8?

Discussion in 'Resolved Bug Reports' started by Rudy, Jan 24, 2011.

  1. Rudy

    Rudy Well-Known Member

    I just ran a test conversion on my forum and, since users will have to reset passwords, I wanted to try it out on my own non-admin account. Clicking on the Forgot Password link just results in a JS error:

    Webpage error details
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET4.0C; .NET4.0E; Zune 4.7; Creative AutoUpdate v1.40.01)
    Timestamp: Mon, 24 Jan 2011 22:48:05 UTC
    Message: 'error' is null or not an object
    Line: 913
    Char: 4
    Code: 0
    (Blocked out the IP address for now, but if support staff needs it, I can do so via PM.)

    Since most users are using IE on my sites, and passwords will need to be reset, I wanted to check if this is a problem in my particular browser, or something legit that may need fixing in XF itself.

    Tried a search here but came up empty....
  2. Kier

    Kier XenForo Developer Staff Member

    Can you reproduce that here on XenForo.com? I just tried with IE8 and it was fine.
  3. Rudy

    Rudy Well-Known Member


    I've just tried it with IE8 here on the XF forum, and the feature works properly. It must be something related to my setup, or the server. I only have it set up as a temporary forum on a dedicated server which we run another forum on, as I'm testing an import from SMF2 --> vB3.8 --> XF. I also notice in the upper righthand corner a horizontal progress "throbber" (if that is what you call it) that stays on the page permanently while it is trying to load.

    It also occured to me that I'm using 64-bit IE8, as I know it has a few quirks to it. But since the feature works here, I am thinking it must be something on my end and not XF. When I did the upgrade to RC1, I loaded a complete new set of files.

    I am going to ask a couple of my moderators to try retrieving a password with IE8 to see if they have the same problem.

    I'm just trying to think of what I should try next. I'll be back!
  4. Kier

    Kier XenForo Developer Staff Member

    Good luck, let us know what you find.
  5. Rudy

    Rudy Well-Known Member

    Update: it does not work in Google Chrome either. When I try it using Chrome, the forum dims, but the window never opens up and overlays the forum.

    I have a working "test forum" on another server (same host, but shared account), and it works properly there. It must be something in our server configuration on the dedicated server. I may actually check my Apache config files, as we had some safeguards in place and some caching instructions as well.

    I don't even know if this is worth pursuing anymore. Once I convert the forum, it is going to live on the shared server until we get enough traffic (and income) to move to a larger account.

    Thanks for checking!
  6. Mike

    Mike XenForo Developer Staff Member

    Check that all the files were uploaded properly - the line number there seems to correspond with the beta 5 version of xenforo.js, not the RC1 version.
  7. Rudy

    Rudy Well-Known Member

    I am going to re-run the upgrade when I get a chance--I do have RC1 on my live "test" forum, but I'm thinking that for the temporary forum I'm testing conversions with, I unzipped the files but never copied them over to the directory as I should have. Sure enough, I just checked and that conversion-testing forum is still on Beta 5. (My memory is not what it used to be!)

    Although even with a complete Beta 5 installation, it should work. There are other JS-related quirks I'm finding now. Let me give it a boost to RC1 and see if it continues. I have a feeling it might, as it is probably server-related due to all of the caching and/or file protection I have set up on our dedicated box. I'll keep you posted, and thanks Mike!
  8. Rudy

    Rudy Well-Known Member

    I'm digging up this old thread, as I think I've found the problem. A rather unexpected one, at that!

    I just ran a test import for the new license I bought two weeks ago. When I installed it within the site's directory, I once again started getting the same strange errors. The alerts were not auto-loading. When I typed in a username, no suggestions were coming up in the list. One or two buttons were not working. And when logging into the admin control panel, the logo normally zooms out, and the control panel loads; in my case, the logo stayed zoomed in, and the control panel would not load until I refreshed the screen.

    Here is the culprit, straight out of .htaccess:

    php_value output_handler ob_gzhandler
    I should note that I've been using this for several years, have tried just about every package under the sun (several different forum systems, Wordpress, a few CMS systems, a couple of shopping cart systems like osCommerce, and plenty others), and all of my own code, and have never seen it wreak havoc with anything. (The only thing I had problems with was vBulletin, because they chose to enable gzip encoding by default. So, I would have to comment that line out to set vB to not use the gzip encoding.)

    This does not depend on OS as, when I first reported this problem, it was on our dedicated server which runs FreeBSD 8. This virtual dedicated server we're on with the new forum runs Ubuntu 10. Both servers had this line in .htaccess, and both exhibited the same problems.

    Also, for the sake of experimentation, I tried changing the JQuery hosting option from my own local copy to JQuery CDN, and it still exhibited the problem.

    So, there is something in gzip compression that does not play nice with XF. If you can't duplicate it on your systems, let me know.
  9. Rudy

    Rudy Well-Known Member

    I'm wondering if this should have a thread title change to reflect the gzip issue that I discovered was causing the problems. I would also be curious to know if the Apache gzip module causes a similar problem (mod_gzip, I think). I can't test it though, unless I try to enable it on my own computer here at home.

Share This Page