1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

For Mike.

Discussion in 'Installation, Upgrade, and Import Support' started by wi11ie, Feb 10, 2011.

  1. wi11ie

    wi11ie Member

    Uploaded all in upload folder to xen folder on server. Modified the config.php file went to browser, typed in www.xxxxxx.com/xen/install like in instruction and got

    Fatal error: main() [function.require]: Failed opening required 'Zend/Controller/Request/Abstract.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/xxxxxx/php') in /home/xxxxxx/public_html/xen/library/Zend/Controller/Request/Http.php on line 1065

    Abstract.php is in the uploaded
    Controller/Request folder

    Any Ideas ??

    wi11ie, Yesterday at 8:22 PM Edit Report
    #1 Reply
    Mike XenForo Developer

    Looks like your include path didn't change. I also see a specific value for the include path that applies to your site.

    This likely means that it was set via php_admin_value by your host. Please contact them, as this is a server misconfiguration. (The include path should be set by php_value.)
  2. wi11ie

    wi11ie Member


    You may want to make some changes to this file xenforo-requirements-test cause the return was the server is ok.
  3. Mike

    Mike XenForo Developer Staff Member

    Well I can't say there's nothing else it could be, but I do see them setting the include_path to an area in your home directory, and that generally indicates that they're setting it in the vhost config.

    I suppose you could upload the contents of the library/Zend directory into /home/xxx/php/Zend and that would likely workaround it.
  4. wi11ie

    wi11ie Member

    Dont get me wrong i agree it is a server problem but if some-one else has the same problem as me and they run xenforo-requirements-test its going to say the server is ok when it isnt if you get what i mean :)

    OK lets try that, uploading now but a good job for tomorrow run install to see if it works:)

    Do i need to delete Zend out of the library folder or rename it?
  5. Mike

    Mike XenForo Developer Staff Member

    No, leave it there.
  6. wi11ie

    wi11ie Member

    Created php folder in /home/xxx uploaded Zend to it ran install and still get the same error
  7. Mike

    Mike XenForo Developer Staff Member

    If your host won't make the change, I don't really see any way around it unfortunately.
  8. wi11ie

    wi11ie Member

    Hi Mike
    I received this from my host

    Please accept my apologies for the delay. We had a few issues trying to figure out what was wrong. It seems to us that there is a flaw in the script. We have had to manually edit a few of the php files from the script in order to remove the errors. We have included the exact path of the script in the php files. This is a small work around but I suggest that the people who create the script look in to how they include files in their php scripts. It would be much simpler for them to use exact paths.

    At least now the install starts and gets as far as asking me for database details

    MySQL Server: localhost
    MySQL Port:3306

    asks for
    MySQL User Name:

    MySQL Password:

    MySQL Database Name

    which i put in and then i hit the test and generate configuration and it crashes

    Fatal error: main() [function.require]: Failed opening required 'Zend/Db/Adapter/Abstract.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/xxxxx/php') in /home/xxxxx/public_html/Zen/library/Zend/Db/Adapter/Mysqli.php on line 550
  9. Brogan

    Brogan XenForo Moderator Staff Member

    That approach really isn't going to work as the next time you upgrade, the files will be overwritten.

    Can you ask your host to clarify exactly what it is they edited?
  10. Mike

    Mike XenForo Developer Staff Member

    They probably just hardcoded the path into one single Zend Framework file. This is actually an issue within Zend Framework and it's in virtually every ZF file, so it's not something we can really change.

    It certainly wouldn't be easier to use exact paths anyway, as this is installed on infinite server setups and OSes.

    If you can't get it working on your host, then we should be able to give you a refund if that's what you want to do.
  11. wi11ie

    wi11ie Member

    Now that's weird cause i re uploaded the files as they were doing what ever they were doing or after they had done it because i hadnt had an answer from them
    i even put it in a different directory. Yet it started ???

    Attached Files:

  12. wi11ie

    wi11ie Member

    PS Brogan
    I asked :)
  13. wi11ie

    wi11ie Member

    When i mentioned that xenforo is working on hundreds of servers around the world, they decided they will work on the server :):)

    Mike. I really would like to see it work rather that get a refund. That would be be the last resort. :)
    Its a nice forum. i like it, i like the ease with which it can be oerated and the functions it has :):)
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Good to hear the host is willing to make some changes.
    Hopefully they can make it possible for you to be able to install the software.

    Either that or your last option is to move to another host...
  15. wi11ie

    wi11ie Member

    I thought about that too Brogan but i just paid for another year last Monday :(
  16. wi11ie

    wi11ie Member

    Hi Fellas. This is from my host

    I have been looking in to this and I can't see what it is we are supposed to be changing our end. Is there any information which they have provided you with?

    If you could ask them to give me some instructions as to what exactly needs to be changed.
  17. Mike

    Mike XenForo Developer Staff Member

    Well, it's quite hard for us to say where exactly the issue is coming from, as it's down to their configuration. What I expect is that their Apache vhost configuration specifies "php_admin_value include_path <value here>", when it should be "php_value include_path <value here>" (this is covered here: http://php.dzone.com/news/setincludepath-failing).
  18. wi11ie

    wi11ie Member

    Thanks Mike i have sent the text to him :)

    Would that stop VB from working ? It was installed on his server about 4 years ago and works well :)
  19. Mike

    Mike XenForo Developer Staff Member

    No, it's a fairly obscure feature of PHP.
  20. wi11ie

    wi11ie Member

    Hi Mike. He replied

    That was set to php_admin_value I have now changed that to php_value and have restarted apache. If you could please try and use it again and see if it works now that would be great.

    Still the same problem
    Fatal error: main() [function.require]: Failed opening required 'Zend/Db/Adapter/Abstract.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/wiiecom/php') in /home/wiiecom/public_html/Zen/library/Zend/Db/Adapter/Mysqli.php on line 550

Share This Page