1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Firefox + ClearType + Opacity

Discussion in 'Resolved Bug Reports' started by Luke F, Aug 12, 2010.

  1. Luke F

    Luke F Well-Known Member

    There is a known and yet to be fixed (even in 4) bug in Firefox where text in transparent elements will look awful (text turns strange colours) if their opacity is < 1 (even without animation) if ClearType is enabled on Windows.

    The workaround is to make all elements where opacity is adjusted (such as forum descriptions, quick reply posting, etc.) have a solid background (anything but transparent, none or undefined). I would like to not have to do this manually when xenForo is released, as the vast majority of my users use Firefox on Windows :)

    [​IMG]

    [​IMG]
     
    Enigma and KURTZ like this.
  2. Kier

    Kier XenForo Developer Staff Member

    Firefox? Really? I'll have to look into that, as far as I was aware only IE displayed ClearType issues with transparency.
     
  3. Luke F

    Luke F Well-Known Member

    Yup, I use Firefox as my main browser and it happens to sites all over the place, some worse than others :(

    I always make sure my sites don't suffer from the bug, would be cool if xenForo did too :)
     
  4. goyo

    goyo Member

    Strange I don't have this issue with Firefox and ClearType on any Win computers:
    firefox+clearfont.png
     
  5. Mark.B

    Mark.B Well-Known Member

    Tested that in Firefox, I find it does go that strange colour briefly as it is popping up but then loads ok.
     
  6. Freddie

    Freddie Active Member

    Same as Mark.B
     
  7. Disjunto

    Disjunto Well-Known Member

    Yeah that screen seems to be taken mid fade in/out
     
  8. goyo

    goyo Member

    Nope...I've tested XF on other machines when it's fully loaded is perfectly readable without extra colors (opacitiy works well with FF in other pages...I'm actually using it when developing... ).

    Maybe it has to do with your cleartype settings ? In Win7 there's a ClearType text tuner (Control Panel - Adjust ClearType Text).
     
  9. KURTZ

    KURTZ Well-Known Member

    W7 64bit + clear type and FF 3.6.8[​IMG]
     
  10. Nick

    Nick Well-Known Member

    What's with those little arrows next to the "test messges" forum? They're the same chevrons used in the breadcrumb navigation.
     
  11. Luke F

    Luke F Well-Known Member

    In the cases I mentioned it only happens while animating, as those are the only times opacity is less than 1, but it is still very noticable on the forum descriptions.

    KURTZ's and goyo's screenshots appear to have been taken after the animation has completed, when there is no issue as opacity is 1.
     
  12. Dean

    Dean Well-Known Member

    Although I cannot find it, someone was having trouble with js while using a really slow internet connection recently.

    The js did not load and the category popup looked strange? Something like that. Perhaps?
     
  13. Luke F

    Luke F Well-Known Member

    No that's unrelated. As I already said the bug is caused by a lack of background colour, and is easily fixed by making the element in question non-transparent.
     
  14. KURTZ

    KURTZ Well-Known Member

    correct, just a moment before the text was light green like you had previously posted ...
     
    Darkimmortal likes this.
  15. KURTZ

    KURTZ Well-Known Member

    little arrows? :confused: i can't get them ... OMG. i'm tired ... :rolleyes:
     
  16. Nick

    Nick Well-Known Member

    Looks like they're gone now. Maybe they were on my screen and not yours... cause I was playing with the header earlier in Firebug and it happened then. :p
     
  17. Mike

    Mike XenForo Developer Staff Member

    I have to say, even with this pointed out, I still can't see it here. I don't know if my eye just doesn't catch it or if it's specific to certain versions of Windows.
     
  18. Caliburn

    Caliburn Well-Known Member

    I usually have ClearType disabled but enabled it for a quick test. I'm confirming this problem in FF-3.6.8
     
  19. Luke F

    Luke F Well-Known Member

    Are you sure you have ClearType enabled? Take a look here for a static example: http://sandbox.darkimmortal.com/cleartype.html

    I see this:
    [​IMG]
     
  20. Mike

    Mike XenForo Developer Staff Member

    Yeah, I see it. I just don't see it on our tool tips. I don't know if it's the movement or the fast fade, the text just doesn't register until it's up to full opacity anyway.
     
    wangyu1314 likes this.

Share This Page